"Paste Mocha Mask" in AE CC2014 not working

Shape data exported from Mocha Pro (Mac, v4.0.1 build 9018) is not working for me when using “Paste Mocha Mask” in After Effects CC2014 (latest update, v13.1.1.3).

I can paste data into AE CC (v12.2.1.5) just fine; it’s just the latest Adobe release that is not working for me (I believe the previous CC2014 point release worked, but can’t confirm).

Is anyone else having this issue, or is there something I might be missing?
Many thanks!

Have you tried re-installing your shape plugin? You can download that here: Boris FX | Downloads

Otherwise, it may just be that your shapes do not line up on the first frame, make sure your data is not somewhere else in the comp.

Please let me know if you have any questions and I will be happy to help.

Cheers,
Mary

I tried re-installing the plugin and still nothing.

I can paste shape data as an effect via a cmd-V / Edit>Paste, but there is no data at all inserted when using “Paste Mocha Mask.” (I would expect an animated AE mask shape as in previous versions)

Can you confirm that the “Paste Mocha Mask” function is working using all latest version Mac software? (Mocha Pro v4.0.1 build 9018 + AE CC2014 v13.1.1.3). I see that the Mocha AE plugins have been updated with the latest October point release of AE CC2014 (New features summary | Latest release of After Effects)

Thanks for your help!

I have the same problem. Still no solution?

I’ve had success with different AE projects as well as failure with others. I can’t seem to find any consistency as to why certain projects / comps work and others don’t.

My solution (though not efficient or preferred) is to do the “Paste Mocha Mask” operation on a new comp/layer in AE CC (or other AE version) and then importing into my AE CC 2014 project (and subsequently copy/pasting the mask data to my intended layer).

Having same problem here - the keyframe data for the mask is the same for all frames. basically frame 1 is being copied into all the other keys, they aren’t being filled in with the correct data for any frame after 1

 

SOLUTION : workaround - render out the layer as a matter clip. works but not ideal.

That’s a bit of a different problem than I was experiencing…

I was not getting ANY keyframe data at all. I would execute “Paste Mocha Mask” and nothing at all would happen. I would be interested if using an earlier version of AE would work for you similar to how I was getting around the problem.

<span style=“color: #1f1f1f; font-family: ‘Source Sans Pro’, Helvetica, sans-serif;”><span style=“font-size: 15px; font-weight: 600; line-height: 21.4285507202148px;”>I have the same problem. </span></span>

<span style=“color: #1f1f1f; font-family: ‘Source Sans Pro’, Helvetica, sans-serif;”><span style=“font-size: 15px; font-weight: 600; line-height: 21.4285507202148px;”>Any solution? please</span></span>

I have the same problem.

Any solution? please

I’ve discovered the problem, but not the solution.
The problem is that Mocha “paste” the shape data to cero from the frame 1 to the frame you setted as the IN point.
So all the data is moved the number of frames there are between the 0 frame and your IN frame.
You could solve it working in a new compsosition with the total length of you footage, but this is not an elegant solution.

As you can see in this picture, Mocha copy several keyframes starting in 0, but the job doesn’t starts in 0 but in my case in 75.

[caption id="" align=“alignnone” width=“967”] timelien[/caption]

I’m glad you found a solution to your issue.

Unfortunately, the issue I am having is that nothing is pasting into AE CC2014 using “Paste Mocha Mask” - no masks or keyframes at all.
If I just do a “paste” (Cmd-V) onto the layer, the shape data works in plugin form, but I can’t get “Paste Mocha Mask” to work… again, my solution that does work is to use AE CC (v12) as an in-between…

Hi,

did you check pasting into a text file? There you can check if the info is or not into the clipboard.

Good luck!!

Yes - I’ve tried several ways :slight_smile:

“Paste Mocha Mask” works fine for me in the previous version of AE CC (v12), just not in AE CC2014…

Hi.

I had “similar” problem but it seems that AE footage iterpolation was the one that messed things up as Mocha had super solid lock

on masks but in AE they went totally off.

 

 

FYI - My issues seem to be solved with the latest Mocha Pro update (v4.1.1 build 9621, released Jan 15, 2015).

Since I updated, every instance of “Paste Mocha Mask” I have tried is functioning as expected.

Thanks!

BTW where could I get the update for Mocha AE CC? In “current versions Dwnload” I can’t see The AE CC version.

 

Help please.

I have the exact same issue in AE 12.2.1.5 and Mocha AE. I have my moving matte tracking nicely in mocha, all other layers switched off, copy shape data to clipboard, then edit>paste mocha mask on my footage in AE - it pastes my shape for the first frame only and remains static as i scrub forwards in the timeline.

Please, anyone got a workaround yet?

Cheers!

 

Have you checked forward on the comp? I say this because, when I paste the mocha mask, it uses the first frame of my comp as “0000”, even if my comp starts at “1234”, so, if my mask starts at “1234”, the info will be on frame “1234”+“1234”=“2468”. I don’t know if this solves your issue…

Thanks sgrobpla

You are right, it seems the keyframes do come back into AE but with the timings of the entire piece of original footage. So where I was working on a single shot from about halfway through the video, the keyframes were completely out. As a workaround, I rendered out my comp from AE before going over to mocha. I then pulled that render back into my comp and used that to work on in mocha - that way the media that mocha is looking at is exactly the same as my comp.

An extra step and I’m sure there are better ways of doing it but when under the pump, this worked for me!

Cheers!