Pasting Mocha AE Shape Keyframes

Hello, All-
I’m a fairly new user, so my apologies if this issue has been discussed already.
I’ve been pulling my hair out trying to figure out why my shapes won’t animate when copied over to AE. I finally realized that Mocha was using the entire range of my source clip rather than limiting itself to the in/out points provided, so my shape keyframes would be far down the timeline from where they should be. This doesn’t happen when exporting corner pin data for tracking, only shape data.
Now that I know what’s happening, I can at least get my keyframes lined up to where they need to be. However, I’d like to know if it’s user error on my part, and if there’s a step I’m missing.
Thanks!
-Chad

Hello, All-

I’m a fairly new user, so my apologies if this issue has been discussed already.

I’ve been pulling my hair out trying to figure out why my shapes won’t animate when copied over to AE. I finally realized that Mocha was using the entire range of my source clip rather than limiting itself to the in/out points provided, so my shape keyframes would be far down the timeline from where they should be. This doesn’t happen when exporting corner pin data for tracking, only shape data.

Now that I know what’s happening, I can at least get my keyframes lined up to where they need to be. However, I’d like to know if it’s user error on my part, and if there’s a step I’m missing.

Thanks!

-Chad

Thanks, Martin! That will work just fine…
-Chad

Thanks, Martin! That will work just fine…

-Chad

This is one way to do it, and the default for tracking with in/ut points in mocha.

However if you want an immediate line up here is an example.

Say you have a shot that is 100 frames and you set the comp range to 51-100:

  1. Click the “Track in mocha AE” option if you are using CS6, or load mocha if you are using other versions
  2. When the New Project Dialog comes up, set the frame range to 51 and 100
  3. If you are using CS6 when you click OK you will get a “Frame out of range” error, because the in/out points are set. For other programs it will just load the frames and set an offset
  4. If you are using CS6, simply click the Reset buttons on the in and out points to set your frame range to be the whole timeline.

You should now have a timeline that is 49 frames (based on the 100 frame shot), but starting from 0 (depending on your default offset). If you do it the default way you will get the whole frame range, but a set on in and out points.

With this method when you export shapes they will paste from the first frame of your in point in AE.

This is one way to do it, and the default for tracking with in/ut points in mocha.
However if you want an immediate line up here is an example.
Say you have a shot that is 100 frames and you set the comp range to 51-100:

  1. Click the “Track in mocha AE” option if you are using CS6, or load mocha if you are using other versions
  2. When the New Project Dialog comes up, set the frame range to 51 and 100
  3. If you are using CS6 when you click OK you will get a “Frame out of range” error, because the in/out points are set. For other programs it will just load the frames and set an offset
  4. If you are using CS6, simply click the Reset buttons on the in and out points to set your frame range to be the whole timeline.
    You should now have a timeline that is 49 frames (based on the 100 frame shot), but starting from 0 (depending on your default offset). If you do it the default way you will get the whole frame range, but a set on in and out points.
    With this method when you export shapes they will paste from the first frame of your in point in AE.