Pasting Mocha shape problem

Hi, wondering if someone can spot what I’m doing wrong.

Pasting shapes from mocha but they appear to be scaled and moved slightly. See screenshot - sorry for phone pic but internet is down :frowning:

I’ve made sure the settings match the source 1080, HD, 25fps, same length etc but can’t get the shapes to line up. Source is avid dnxhd and I’ve tried with an image sequence but still the same issue.

I’m seeing the exact same thing. Everything looks great in Mocha Pro, then when I paste to After Effects CC, it scales down and changes position. Even the tracking data doesn’t seem to copy correctly. I’ve also checked, and all my frame rates, sizes, aspect ratios, etc. are identical.

Any ideas?

—Quote (Originally by joshgibson)—
I’m seeing the exact same thing. Everything looks great in Mocha Pro, then when I paste to After Effects CC, it scales down and changes position. Even the tracking data doesn’t seem to copy correctly. I’ve also checked, and all my frame rates, sizes, aspect ratios, etc. are identical.

My tracking is just fine in Mocha Pro as well when I turn the surface on - no problems there.

Any ideas?

What it looks like in Mocha: http://d.pr/i/4ECv

After pasting into After Effects CC: http://d.pr/i/ttdj

Running a 15" Retina MacBook Pro with latest versions of both AE CC (12.0.0.404), and Mocha Pro (3.2.1.)
—End Quote—
So on my end I figured out that pre-comping the video I was pasting the mocha mask onto in AE solved the issue. Works just fine.

My footage was scaled down from 4k to 1080p so that was probably what was messing it up. User error on my end. :slight_smile:

What does your tracking look like when you turn on the surface? Is it erratic, or does the surface get very skewed?

Ah! Right, yes the layer sizing!

I’d recommend taking a look at Mamoworld’s plugin MochaImport+ if you plan to use tracking a lot with precomps. The tool really streamlines the process: http://mamoworld.com/tools/mochaimport

Check the aspect ratio, frame rate, and size in mocha and make sure it matches AE. Also, make sure you are pasting data in on the first frame of your clip you tracked in mocha.

There has to be something not lining up, that’s the only time we see these sorts of errors. Try changing the aspect ratio to “custom” and “1.”

Thanks Mary, yeah double checked all those things and it’s the same. Started a new project and it’s the same.

For some reason now all the splines are jumping around the frame when I playback in mocha. Backup file is the same. Two days of roto gone :frowning: