Pasting Over Tracking Data Resizes Pre-Comp

Hi there. I’ve been working in mocha AE to insert photos into frames using tracking and shapes. I’ve tracked a frame using four points over roughly ~400 frames, but I’m running into issues getting the tracking data to work properly in After Effects once pasted onto a pre-comp.

Once pasted over, the picture being used becomes extremely small and doesn’t fit into the frame I designated in mocha. See the screenshots below for what it looks like in After Effects compared to mocha.

 

Any ideas? I’ve tried adjusting the planar surface but when I activate the overlay, it’s nowhere to be found. I think it may have gone off screen somewhere.

 

Thanks.

If you leave the planar surface on the frame and instead make the insert in AE into a precomp and size the layer to the comp size, you should just be able to corner pin the smaller surface onto that.

Essentially, select your insert.
Then go to transform>fit to comp
Precomp that and move ALL attributes into the comp.

Now you can paste your corner pin.

Cheers,
Mary

 

Thanks for the quick reply, Mary. I’ve followed your steps but I’m still running into the issue. Here’s the steps I’ve taken.

Tracked the frame in Mocha. (Haven’t modified the planar surface since the start, and trying to edit it in mocha now won’t work as I can’t find it in the workspace. It appears normally for my other layers. Not sure if there is a way to reset the position of just the surface, or if it really matters… just spinning the gears here.)

Select the “Export tracking data” button, then the AE Corner Pin [supports motion blur] option.

I copy that to my clipboard, then move over to AE. In AE, I drop my picture above the movie file and transform it to fit the comp. Pre-compose it, then paste the tracking data onto the newly made composition that contains the picture.

This continues to produce a workspace that looks like the first picture above. Is there anything further I should be doing in After Effects to properly fit the picture to the frame?

Sorry if this is an obvious fix. I’ve watched a bunch of tutorials but I’m still learning mocha as I go. I have to say, it is a pretty incredible piece of software when everything’s going right.

You have to have the surface where you want the corner pin. Align the surface to the frame in layer controls then manipulate it to the location you need.

Aha! That solves that, I’ve reset the position of my surface so that I can adjust it and managed to get it to the right size, fixing my sizing issue.

Is there a way to keyframe the surface in mocha, much like the regular tracking? When the frame moves, the surface can’t quite keep up with it and any changes I make to one frame of the surface changes the other frames as well. Is this what the AdjustTrack panel is used for? It appears to be allowing me to change the tracking of the surface.

Yes, adjust track is how you correct the track. :slight_smile: https://www.imagineersystems.com/videos/quick-tip-adjust-track/

Amazing! You’ve solved all my problems. If I remember after exporting, I’ll try and post an example of what my video looks like now that I’ve gotten the tracking down. Just some fine-tuning and it should be finished.

Thanks so much, Mary!

Happy to help, glad you’re all set!

I’m actually still lost what happened? I had a similar issue when I tracked in Mocha, following a tutorial I still am really lost on these steps. I’d love to see an official Mocha-AE tutorial on this sort of “easy” effect.

Take a moving footage of a frame, track in AE, then do the magic in AE :).

That tutorial exists. :slight_smile:

http://www.imagineersystems.com/videos/align-surface-and-mismatched/

Also this has similar information:

http://www.imagineersystems.com/videos/mocha-fundamentals-chapter-8a-corner-pin-data-after-effects/