Perfect Mocha Track

So what I’m trying to do, is track a position from a video I shot, then have and explosion stay in that same spot throughout the shot. So I select the area I want it to track, then track, and everything is happy dandy and mocha tracks it perfect, but when I paste it on to the explosion in AE, it doesn’t work. It’s all whacky. I’ve made it so the explosion comp is the same size as the video, both are are the first keyframe. Don’t really know what’s going on, I’m a newbie at this so go easy on me! :stuck_out_tongue:
(Using AE CS5 and Mocha 2.2.0)
Thanks in advance!
Jake

—Quote (Originally by martinb)—
Hi Jorge,
If the image is cutting off it would be the footage, not the tracking data that is causing that. If you follow along further with the tutorial you can see he adjusts it to stop the clipped frames coming in. The only way you can avoid the cut-off is using footage that doesn’t clip at the top, or hide the cut-off point.
—End Quote—
Sir, So you are saying that I need to use another footage effect? (explosion), or is the “hide cut-off point” a button in AE CS4 and I have a solution?, because I did exactly what the tutorial mentions, if you follow the tutorial when that problem is showed ,then did not show the problem solved, then start talking about Action Essentials 2, so, I do not know is there a solution,
sorry if I do not get your point, I’m learning English
Thanks Sir

—Quote (Originally by Jorge Chile)—
Hi everyone, I’m from Chile, SouthAmerica
First of all, have to say that this is my first forum account, I have never participate in this kind of system, for this reason, I’m sorry if I miss the point…, the thing is that I’m trying to create an explosion with AE cs4, and mocha, + Actions essentials 2, well, the problem is that the explosion looks cut when the image (camera) moves because of the “impact” of the explosion, the video (20 seconds) is about a guy walking and then something explodes and the camera goes up and down, shake, when the camera do that the expliosion is cut half… I’m learning form a tutorial on the web, I followed step by step to solve that problem,: first, go to mocha, then export trasnform data, then in AE cs4 create a null object then paste trasnform data in it, then, edit null object (desactivate scale, copy anchor position to position, then desactivate anchor position and finally change numbers in anchors position to cero) but nothing happens, my explosion is still cut when the camera
moves, need help please, the problem I have is explainned in this video (08:46 minutes (VIDEO COPILOT | After Effects Tutorials, Plug-ins and Stock Footage for Post Production Professionals))
Greetings
sorry about my english, I’m learning :rolleyes:
—End Quote—
Video VIDEO COPILOT | After Effects Tutorials, Plug-ins and Stock Footage for Post Production Professionals

Hi everyone, I’m from Chile, SouthAmerica
First of all, have to say that this is my first forum account, I have never participate in this kind of system, for this reason, I’m sorry if I miss the point…, the thing is that I’m trying to create an explosion with AE cs4, and mocha, + Actions essentials 2, well, the problem is that the explosion looks cut when the image (camera) moves because of the “impact” of the explosion, the video (20 seconds) is about a guy walking and then something explodes and the camera goes up and down, shake, when the camera do that the expliosion is cut half… I’m learning form a tutorial on the web, I followed step by step to solve that problem,: first, go to mocha, then export trasnform data, then in AE cs4 create a null object then paste trasnform data in it, then, edit null object (desactivate scale, copy anchor position to position, then desactivate anchor position and finally change numbers in anchors position to cero) but nothing happens, my explosion is still cut when the camera
moves, need help please, the problem I have is explainned in this video (08:46 minutes)
Greetings
sorry about my english, I’m learning :rolleyes:

—Quote (Originally by martinb)—
If you are talking about the point where the explosion looks like it has been cut off in the top of the frame, then it has to do with the placement of the footage.
Is the explosion locking onto the ground correctly?
—End Quote—
Hi Sir, the explosion is correct in the ground and follows the tracking data correctly, sir, did you see the tutorial i’ve mentioned, is the same problem, in 08:46 minutes VIDEO COPILOT | After Effects Tutorials, Plug-ins and Stock Footage for Post Production Professionals there you can see how the explosion is cut off at the top of the frame, the tutorial mentioned clearly what is the problem and how it is supposed to be fixed, but i cant’t solve it sir.
Thanks

Hi Jorge,
If the image is cutting off it would be the footage, not the tracking data that is causing that. If you follow along further with the tutorial you can see he adjusts it to stop the clipped frames coming in. The only way you can avoid the cut-off is using footage that doesn’t clip at the top, or hide the cut-off point.

If you are talking about the point where the explosion looks like it has been cut off in the top of the frame, then it has to do with the placement of the footage.
Is the explosion locking onto the ground correctly?

If you are using the transform data rather than a corner pin and you are not using a precomposed frame like he is doing, then you should not see the cutoff.
So:

  1. Use transform data, NOT corner pin data to get his method
  2. Don’t precompose the explosion footage or you’ll clip the frame
    Since this is more of a tutorial workflow issue, I would suggest you discuss the problem in the video copilot tutorial section:
    VIDEO COPILOT | After Effects Tutorials, Plug-ins and Stock Footage for Post Production Professionals

Hi Jake,
It sounds like you’re trying to stabilize your shot around your explosion. Have you aligned the surface of the track to the frame you want to explosion to be centered on? Have you exported the tracking data as a corner pin or as transform data? Let me know a few more details so I can make sure I’m giving you the right advice.
Stabilization in mocha ae is a little trickier than in mocha pro, which automates the process for you.
Cheers,
Mary

Awesome, Jake. Glad to help.

Hi Jake,

Yes, it sounds like your parameters are off OR your clip is shortened in the mocha file. Check the clip frame-range and try to extend it to the correct range. Check the aspect ratio, frame rate, range, etc both in mocha and ae.

You will need to align surface to the frame in your track that you want to be the “center” of the explosion, if that makes sense. Essentially you’re saying “this is the correct frame up of what I want, translate AROUND this frame.” Then you paste the data in ae on the first frame, like everything out of mocha. I would just use translation, corner pin might warp your footage and it sounds like you’re just looking for translation.

A screen-grab always helps us diagnose problems. Alternatively, you can send me your files to my email or I can provide you with FTP information and take a look at your shot.

Cheers,
Mary

Hi Jake,

It sounds like you’re trying to stabilize your shot around your explosion. Have you aligned the surface of the track to the frame you want to explosion to be centered on? Have you exported the tracking data as a corner pin or as transform data? Let me know a few more details so I can make sure I’m giving you the right advice.

Stabilization in mocha ae is a little trickier than in mocha pro, which automates the process for you.

Cheers,
Mary

Hi Jake,
Yes, it sounds like your parameters are off OR your clip is shortened in the mocha file. Check the clip frame-range and try to extend it to the correct range. Check the aspect ratio, frame rate, range, etc both in mocha and ae.
You will need to align surface to the frame in your track that you want to be the “center” of the explosion, if that makes sense. Essentially you’re saying “this is the correct frame up of what I want, translate AROUND this frame.” Then you paste the data in ae on the first frame, like everything out of mocha. I would just use translation, corner pin might warp your footage and it sounds like you’re just looking for translation.
A screen-grab always helps us diagnose problems. Alternatively, you can send me your files to my email or I can provide you with FTP information and take a look at your shot.
Cheers,
Mary

Hi Jake,
Without seeing what you’re doing, I can’t tell you if you’re tracking incorrectly or not. I can look at your footage and file and help you that way, but I also recommend that you watch some of our tutorials.
This mocha ae to after effects stabilization tutorial and see if you can get your answer here. It’s worth sitting through from beginning to end, and goes over every single step you’ll need to do to stabilize footage in AE.
http://www.imagineersystems.com/videos/mochaimport-stabilize-without-scaling-footage/view
Cheers,
Mary

Hi Jake,

Without seeing what you’re doing, I can’t tell you if you’re tracking incorrectly or not. I can look at your footage and file and help you that way, but I also recommend that you watch some of our tutorials.

This mocha ae to after effects stabilization tutorial and see if you can get your answer here. It’s worth sitting through from beginning to end, and goes over every single step you’ll need to do to stabilize footage in AE.

http://www.imagineersystems.com/videos/mochaimport-stabilize-without-scaling-footage/view

Cheers,
Mary

Awesome, Jake. Glad to help.

First off, thanks for all the help! I really appreciate it.
So, instead of a .mov, I made the clip into a .jpeg sequence and mocha finally got it as 149 frames, so that part is all good. Also the tracking seems much better but it’s still off.
—Quote—
You will need to align surface to the frame in your track that you want to be the “center” of the explosion, if that makes sense. Essentially you’re saying “this is the correct frame up of what I want, translate AROUND this frame.” Then you paste the data in ae on the first frame, like everything out of mocha. I would just use translation, corner pin might warp your footage and it sounds like you’re just looking for translation.
—End Quote—
Still a bit confused on what exactly you mean by this. :o
I feel like I’m doing something wrong in mocha, like tracking the wrong area or starting at the wrong place.
Jake

So what I’m trying to do, is track a position from a video I shot, then have and explosion stay in that same spot throughout the shot. So I select the area I want it to track, then track, and everything is happy dandy and mocha tracks it perfect, but when I paste it on to the explosion in AE, it doesn’t work. It’s all whacky. I’ve made it so the explosion comp is the same size as the video, both are are the first keyframe. Don’t really know what’s going on, I’m a newbie at this so go easy on me! :stuck_out_tongue:

(Using AE CS5 and Mocha 2.2.0)

Thanks in advance!
Jake

Thanks for the quick reply!
Before I answer your questions, I want to point out that I’ve noticed that the frame range for this clip is 0 to 77 when the actual clip is 149 frames.
So, I open mocha, import the clip (Correct framerate), select the x-spline tool, and select the plane I wish to track. -Now I’ve only seen a few tutorials on which part to track, but from the ones I’ve seen, it seems I should be tracking the general area the explosion would be.- I select the area, then track it from the first frame. Tracks perfect. I click surface, then grid and make sure it’s the same slope and angle as the video-Another question I have is, if I didn’t want the explosion to start directly at the first frame, do I do anything differently? Like start tracking from a different frame or anything? AND Do I click ‘Align Surface’?- After that I click export tracking data and chose the last option; Transformation data, but I’ve also tried the Corner Pin [Supports Motion Blur] then Copy to clipboard.
Here, I head back over to AE, Layer>New>Solid (Would a null obj. work too?) then past my tracking data on the solid.-If I were to scrub through here, the timing and scaling would be off, plus it would only last 77 frames (See top of post) then, layer>Pre-compose with the ‘leave all attributes’ option, drag my explosion above the solid, move it to where necessary then hide the solid.
So that’s what I do, if you don’t understand something, please let me know, I’d also be happy to do a screen recording if that would make it easier to determine what I’m doing wrong.
Thanks for you time and help!
Jake

Thanks for the quick reply!

Before I answer your questions, I want to point out that I’ve noticed that the frame range for this clip is 0 to 77 when the actual clip is 149 frames.

So, I open mocha, import the clip (Correct framerate), select the x-spline tool, and select the plane I wish to track. -Now I’ve only seen a few tutorials on which part to track, but from the ones I’ve seen, it seems I should be tracking the general area the explosion would be.- I select the area, then track it from the first frame. Tracks perfect. I click surface, then grid and make sure it’s the same slope and angle as the video-Another question I have is, if I didn’t want the explosion to start directly at the first frame, do I do anything differently? Like start tracking from a different frame or anything? AND Do I click ‘Align Surface’?- After that I click export tracking data and chose the last option; Transformation data, but I’ve also tried the Corner Pin [Supports Motion Blur] then Copy to clipboard.

Here, I head back over to AE, Layer>New>Solid (Would a null obj. work too?) then past my tracking data on the solid.-If I were to scrub through here, the timing and scaling would be off, plus it would only last 77 frames (See top of post) then, layer>Pre-compose with the ‘leave all attributes’ option, drag my explosion above the solid, move it to where necessary then hide the solid.

So that’s what I do, if you don’t understand something, please let me know, I’d also be happy to do a screen recording if that would make it easier to determine what I’m doing wrong.

Thanks for you time and help!
Jake