PI - Degrading Preview Speed & Emitter Coverage Problem

System & NLE: Win 10 64 bit, 32 Gb DDR4, SSD drives, Vegas Pro 19 with Continuum 2021.5 (Far more detailed system specs close this post)

I have multiple issues with sluggish response and occasional crashes with VP 19 which may be caused by a basic consumer graphics card that just can’t handle things, but for this post I just wish to solve the two issues that are PI specific.

1. Degrading Preview

Only 1 track, one background clip, one single emitter (for now). I purposely rendered a very light footprint, only 15 fps clip as work background to take a load off of preview for use in PI that I will eventually replace.

While perhaps not real time fast when viewing in PI, it does not degrade as you can see it doing so in the below when viewed in the Vegas timeline.

One can see this degradation starting about a third in in this video screen shot:

Slow Down - 0:51 min.

2. Emitter Area Coverage

The particles do not cover entire screen/frame. I have not even started doing anything with this emitter aside from position for I have to solve these two issues before I can continue.

First photo screenshot is at first frame, second is at last. The added horizontal line in the second shows where the emitter field stops once it reaches that area.

Vegas Pro Project Properties:

Vegas Pro Video Preferences settings:

MediaInfo on 15 FPS temporary/stand-in clip for PI emitter:

Thank you for your help.


*GENERAL SYSTEM SPECS: *

Win 10 64 bit Home
MSI Performance B450 Gaming Plus mobo
Ryzen 5 1600 CPU (6 actual cores, no overclocking)
Crucial 3200 Mhz DDR4 2 x 16 Gb - XMP
Dual 24" LCD Samsung Monitors*
OS on Samsung Pro 850 SSD + 2 Logical SSD + 3 Mechanical HDDs (SATA non-RAID)
nVidia GT 710 2 Gb. DDR3 Video Card
*Behringer UMC 204HD 192K USB + MIDI Audio Interface *

( Monitors manf 2013 *
Brightness 300 cd/m2
Color support 16.7Million
Dynamic Contrast Ration 70,000:1
Static Contrast Ratio 1,000:1
Response time 5ms)

______________

CPU: AMD Ryzen™ 5 1600

# of CPU Cores - 6
# of Threads - 12
Max. Boost Clock - Up to 3.6GHz
Base Clock - 3.2GHz
Total L1 Cache - 576KB
Total L2 Cache - 3MB
Total L3 Cache - 16MB
Default TDP - 65W
Processor Technology for CPU Cores - 14nm
Unlocked for Overclocking - Yes
CPU Socket - AM4
Max. Operating Temperature (Tjmax) - 95°C
Launch Date - 4/11/2017

https://www.amd.com/en/products/cpu/amd-ryzen-5-1600

______________

MOBO: MSI Gaming Plus B450

CPU (MAX SUPPORT) - RYZEN 9
*SOCKET - AM4 *
CHIPSET - AMD® B450 Chipset
DDR4 MEMORY - 1866/ 2133/ 2400/ 2667Mhz (by JEDEC)
- 2667/ 2800/ 2933/ 3000/ 3066/ 3200/ 3466 MHz (by A-XMP OC MODE)
MEMORY CHANNEL - Dual
DIMM SLOTS - 4
*MAX MEMORY (GB) - 128 *
PCI-E X16 - 2
*PCI-E GEN - Gen3(16) (8), Gen2(4) *
*PCI-E X1 - 4 *
SATAIII - 6
M.2 SLOT - 1
RAID - 0/1/10

https://www.msi.com/Motherboard/B450-GAMING-PLUS/Specification

______________

GPU:

EVGA GeForce GT 710 2 GB (Single Slot, Dual DVI)

Specifications:

Base Clock: 954 MHZ
Memory Clock: 1800 MHz Effective
CUDA Cores: 192
Bus Type: PCIe 2.0
Memory Detail: 2048MB DDR3
Memory Bit Width: 64 Bit
Memory Speed: 1.1ns
Memory Bandwidth: 14.4 GB/s
UPC: 843368039257
EAN: 4250812412423

Key Features:

1x Dual-Link DVI-I 1x Single-Link DVI-D
HDMI 1.4a connector
Microsoft DirectX 12 API (feature level 11_0) Support
NVIDIA Adaptive Vertical Sync
NVIDIA CUDA Technology with OpenCL support
NVIDIA FXAA Technology
NVIDIA PhysX technology
NVIDIA PureVideo HD Technology
OpenGL 4.6 Support
PCI Express 2.0 support

https://www.evga.com/products/specs/gpu.aspx?pn=f345c5ec-d00d-4818-9b43-79885e8a161f

I’m not familiar with caching or similar in Vegas so I’ll see if anybody else has ideas about that, but as for the coverage issue… are you seeing that inside PI too, or only back in Vegas?

Is your Nvidia driver updated? (or at least fairly recent)

One workaround would be to render directly out of PI and then import that rendered clip into your project as a regular video layer (and remove/disable PI as an effect).

Hi Alan,

The coverage issue happens in PI and Vegas - it’s WYSIWYG in both. I’ve rendered out 21 seconds of the test clip with PI from Vegas timeline as a basic CBR MPEG-4 @4000 kb/s:

Coverage Issue

Hi, your GPU isn’t the best so PI + Colour Curves is prob the reason it slows down, as more particles are created the more processes are happening,
Try Dynamic Ram Preview to se if it runs smoother, i have to do that on my machine with PI.
In your picture you have Preview on Preview (Half),
If you look at the bottom of the screen -
Preview 960x540
Display 1006x566
that means Vegas is having to down-scale the media from 1920x1080 to 960x540 but then also upscale to 1006x566 for the preview, I’m not sure if that is exactly the case but try setting it to Preview (Full), i find that plays better.

It also shows the media is on track 3, what is on tracks 1 & 2?, the coverage prob looks like some kind of layer issue/offset or masking, have done anything with Pixel Chooser?

1 Like

Your graphics card is a low end card from 8 years ago? Maybe consider upgrading?

My mid-tier RTX 3070 is 4700% faster.

@Gid.Joiner, @RomanAnthony - I want to acknowledge and thank you for your input, but I can’t reply in detail for now due a health issue. I’ll try to respond within the next 48 hours.

:joy: So how much faster is my 3090 Suprim :joy:
@newsoniclight no worries, i tried adding Text & Colour Curves, i messed around a little but the only way i could repeat what’s in your video was by adding a mask with the in-built Pixel chooser in PI,

Post deleted by user.

Post deleted by user.

Regardless of system hardware, somebody asked if you had a mask or PixelChooser enabled for PI (to explain the cutoff region).

Also I’d suggest trying the exact same PI setup in a simpler project… maybe even a still image at the same resolution as a way to remove variables.

Post deleted by user.

There is no seeming solution to any of this therefore I have removed all my most recent posts and request that the entire thread be deleted. I thank those who replied, but I don’t want to further waste anybody’s time. I will no longer be watching this thread.