PI, Pixel Chooser with Mocha.... only the matte moves in Resolve

I’m playing around with the Pixel Chooser and Mocha tracking and not having much luck. Maybe my workflow is wrong, but I’m not sure, so I’m here…
– FYI I’m in Resolve –
So here’s what I’m trying to figure out…
I have a shot of a car driving toward the camera and applied Particle Illusion to the clip in the timeline.
I then launched PI and created the particle I wanted to have on the front grill of the car throughout the shot, placed it where I wanted and clicked Apply to return to Resolve.
In the Inspector I twirled down Pixel Chooser / Mocha and clicked on Launch Mocha Mask / Track to launch Mocha.
I drew an X spline around the grill of the car and tracked it forward and back to make sure I got the whole thing, clicked Save then closed Mocha to return to Resolve.
I clicked View Mask / Matte and it tracks perfectly.
But the particle doesn’t move!
How do I get the particle to move along with the matte, or do I need to get it to move another way?
I’d use the Motion Tracker / Mocha option that appears in the Inspector, but it’s disabled for some reason.

You’re using the wrong motion tracker. There are two included with this filter - one for the emitter / camera position and one for the mask position. You used the mask tracker instead of the motion tracker.

• To track the particles into the shot you need to use the Motion Tracker / Mocha option. To use that option you need to enable Transforms for the filter. This is done in the Transforms pop-up near the top of the filter param list. So set the Transforms pop-up to World+Emitter. This will enable the Mocha Tracker option and it will auto-populate the Mocha UI with two search regions, one for the World (Camera) and one for the Emitter. You can set both to the same tracker target when tracking in the Mocha UI.

• In the Transforms pop-up you’ll find 3 ways to utilize the tracked data - it can drive the world (this is the internal camera) or it can drive the emitter position only or both the world and emitter. You’ll see different results depending on the set up you select - I would encourage you to experiment with each so that you can understand the difference between them.

I hope this helps!


Great! Thanks! I’ve been trying to figure out how to get Mocha enabled. Mystery solved!