PI Standalone Emitters not working

Hello,
I downloaded the latest PI Standalone version recently, and while the latest emitters work just fine, I notice that a majority of the older ones do not function properly.

Please see screenshot.
When clicking on the emitter of choice, one expects it to end up on the workspace/stage, but nothing happens.

I have tried restarting/rebooting and I still get the same issue.

Any assistance would be appreciated.

What happens when you click on the window?
Sometimes double clicking on the emitter doesn’t apply it 1st time.

Nothing happens.

I do the usual double click that automatically sends the emitter to the stage - nothing.

I click on the preview image at the top of the screen, all it does is move within that frame - it does not transfer to the stage.

As I said, some of the newer emitters work just fine, but older ones do not.

If you click ‘on the preview image at the top of the screen it does not transfer to the stage’ that’s right, it doesn’t
I meant if you click on the big window on the upper right. where your arrow is pointing ?


Yes i understand that, but you still haven’t answered my question,
What happens if you select the emitter & click on the big window?

Nothing happens.
No matter how many times I click the big window. All I get is a black screen.
No emitter shows up.

Ok thankyou, just to be clear i understood from your very 1st comment that double click wasn’t working but in your pic (below) the emitter is showing in the preview top left,

This says to me that the emitter is there & is being recognised by Particle Illusion but for some reason the double click isn’t responding.

can you share this image from View - Preferences


Here you go (and I appreciate you assisting me in getting this solved)

Hi Kiyasama,

You enable “Click in Stage to Add Emitter” in the preferences.

Thanks
Linh

1 Like

As well as ticking that ‘click in stage’ button @linh mentioned this is a quote from an earlier post -

Alan_Lorence

Mar 17

Anybody on Windows need to triple-click to add a library emitter or scene to the stage? This seems to be an issue on some systems, and I may have found a workaround.

In the Windows Control Panel - Mouse Properties, set the double-click speed slider to the slowest setting.

Does that fix the issue for you in PI?’

1 Like

Yaaaay! It worked!
Thanks so very much!

:+1::+1: What did you do to make it work?

Ticked on the ‘Click in stage’ button. :slight_smile:

:+1: So now that clicking on the big screen works does double clicking one of the emitters from the list on the left now add it to the screen?

Unfortunately, no.
Even with that option clicked, I still can’t double-click from the list to send it directly to the stage.

We’ve found that on some Windows systems it is necessary to triple-click, although we haven’t been able to narrow down why this happens on certain machines. Does triple-click work for you?

-Jason

1 Like

Oh wow, triple clicking DID work. Interesting.