Planar surface difting


#1

I have manually keyed a roto so that it stayed with the shaped that I wanted but when I go to track for the planar surface to follow it drifts off even though my roto does not. What could be causing this and how do you fix this?


#2

It will depend on what you are tracking.

It may be because you do not notice an occlusion that mocha DOES see; moving objects or people that slowly move in front of the area you are trying to track need to be avoided. Also look out for obvious or even “barely there,” consistently moving reflections or shadows; mocha will notice them even if you don’t!

But it could also be that you are not tracking enough or the right area of an object. When tracking surfaces you will usually get a much better track if you include the edges and not just the interior of an object. This is because mocha can define the difference between the background and the foreground and lock on better. You also may need to make your shape larger or track a better area of texture. Remember, mocha is a texture tracker. So if there is no pattern, mocha doesn’t know what to track.

Finally, make sure your layer order isn’t occluding tracks you are trying to make. When you track a layer, the mattes of any active layers above the layer itself are subtracted from the matte of the layer and hence influence the area being tracked. To keep your tracking predictable, it is recommended that you keep your tracking layers on the top of the stack unless you specifically wish to use other layers to subtract from the tracking area of layers beneath it. To monitor what the tracker “sees” as a tracking area, select the Track Matte button in the view control. With this layer order, as long as your track objects from the foreground to the background, you will always have holdouts for the tracks behind them.king and how that object is moving. The roto won’t tell you much about what the track is doing.

Understanding the planar tracker is key to getting a good track. Increasing the Min % of Pixel Used in the track tab can also help.

If your tracker is simply not working properly, there could be a corrupt file in your cache. Delete the contents of your cache folder. You can find your cache folder in your Preferences: File>Preferences wherever you have set it to, but usually somewhere like “C:/MoTemp/”.

Delete the cache folder contents and restart mocha.

If you are new to mocha, I highly recommend watching the Fundamentals of mocha videos here:http://www.imagineersystems.com/video/?tagFilter=mocha%20Fundamentals&&dd=dateOld&orderby=date&order=ASC

They are well worth your time.

Cheers,
Mary


#3

Hello,

“It may be because you do not notice an occlusion that mocha DOES see; moving objects or people that slowly move in front of the area you are trying to track need to be avoided. Also look out for obvious or even “barely there,” consistently moving reflections or shadows; mocha will notice them even if you don’t!”

This is the problem I’m having. A person is moving very close to my track and it’s causing my planar surface to drift, not my actual root shape. Is there a way to root the person out so Mocha doesn’t get confused with the occlusion?

Thank You!

-Corey