Planar surface interpolation

Hello
I am driving insane about this behaviour. Here is my reference shot for the tracking. I start the tracking.

Then of course, there is a cut in the footage (there is always cut in the footage we receive)

When the four corners are again inside my shot, the planar surface has shifted.

So I try to adjust it manually (without going to adjustTrack panel)

But here is the thing : when I come back to my original point, the planar surface has also been modified.

So my point is : how can I correct this, without interfering from other key point ?

Manual Track makes a keyframe. If you don’t make a keyframe first before the track jumps, and then make a keyframe after, it will offset the surface.

So to fix this, on your last good frame, switch to manual track, then on the keyframe controls at the right of the timeline use the key tool to add a keyframe (looks like a key).

Now navigate to your cut and adjust the surface tool in Manual Track back to your desired location.

This should now animate properly, but please let me know if it does not.

Best of luck, that’s an annoying place for a cut right in the middle of a shot.

I should make it clear that in your example you are not actually doing a manual track.
You need to turn on the “Manual track” radio button to do this. Otherwise, you’re just moving the surface to a new position without keyframing it. This is why you see the problem.

But TBH this looks more like an AdjustTrack problem. The manual track seems unnecessary here when you could just adjust the drifting corner and maintain the rest of the track.

Ok I got the idea Mary. So correct me if I am wrong :

  1. I need to automatic track only the good part.
  2. Switch to Manual track for the jump parts (keyframe before and after)

What if I have several jump in my shot ? Do I need to duplicate layer for each good shot ?
How can I delete the automatic track in some area ?

Martin, I tried to use Adjust track, but no success. When I adjust some part, it modifies also before or after. But of course I still need to work on it.

  1. Yes
  2. Yes

You don’t need to duplicate the layer, you just need to manually adjust the track in multiple points. You have to turn Manual Track on to do this.