Plate not rendering on the whole mask (Remove Module)

Hello, I’m trying to remove an overlay text from a shot. For some reason the plate I edited in Photoshop is not applied entirely, as you can see from the image attached. I had this problem with another shot too so I’m pretty sure I’m doing something wrong, although I cant really tell what it’s.
I followed some tutorials from Mocha and did exactly the workflow described - track the text/object and track BG while it’s under the object layer. The masks/tracking for both BG and text look accurate, so don’t think it’s a problem with that.
Any help appreciated. Thanks.


PS: using the Remove Module

I don’t think your tracking can be accurate since you have the bench and ground in the same tracking shape.

You need a track for the ground and a separate track for the bench above that.

Also make sure you are using cleanplates exclusively.

Try that and let me know,
Mary

Hello Mary, thanks for the reply. Just tried separate tracks but still no luck:


Any idea of what that could be?

You have to have background tracks beneath the remove to create a remove, so move your ground track shape under the seat and make sure it covers the text area. Is your cleanplate free of text?

Have you watched our remove module series? I think it would really help you.