Possible bug with Mocha for AE 2.6.1 and AE 5.5 10.5.1.2

After years of using (and beta testing) Mocha, I bumped into what seems to be a bug that affects motion bur on the versions listed in the title bar.

  1. I am using Tutorial #2 (Curious Turtle) as a quick refresher.
  2. I track a small square/image on a contact sheet. Then display and line up the surface corners.
  3. Tracking is modified with Adjust Track so surface tracks perfectly
  4. I then output the corner pin data in 2 different ways
    a. After Effects Corner Pin only, supports RG Warp and MochaImport
    b. After Effects Corner Pin, supports motion blur
  5. The results when an image is compositied to the contact sheet backround using the tracking info follows:
    a. Using Mochaimport / CP Power point mode with After Effects Corner Pin only, supports RG Warp and MochaImport) - image tracks perfectly with background, but turning on AE motion blur and changing parameters yields no motion blur. This worked in AE CS5.
    b. Using Mochaimport /CP Power point mode with (After Effects Corner Pin, supports motion blur). the image starts correctly but drifts displaced over time. If I turn on motion blur i see it shift slightly up and to the right.
  6. I also tried opening up the After Effects Corner Pin(supports motion blur ) test file, copying and pasting it on the image.The image starts correctly but drifts displaced over time . If I turn on motion blur i see it shift slightly up and to the right.
    The current version of Mocha for AE and AE do not allow AE motion blur to be seen when activated in AE, this used to work just fine in AE CS5.
    Another example of a bug with the present version of Mocha for AE 2.6.1 and AE 5.5 10.5.1.2 (these problems did not exist in AE 5.0.)
  7. Tutorial #3 on Curious Turtles Rock Steady DVD
  8. Track the front of a van moving left to right on a desert road.
  9. Adjust the track.
  10. Output Transform data both to clipboard and data file
  11. Create a null and
    a. Paste transform data from clipboard. The visible track in AE is about 500 pixels south of where it should be (tracking the front of the van)
    b. Paste transform data loaded into Mochaimport .Same problem. The visible track in AE is about 500 pixels south of where it should be (tracking the front of the van)
  12. This bug makes AE 5.5 unusable for projects that need Mocha tracking. AE 5.0 did not manifest this problem.
    UPDATE…
    After continued testing this displacement of the track problem seems to be limited to PAL footage (i.e. The Curious Turtle Mocha Training DVD Materials). I eventually tried some NTSC HD clips and they work fine. But still an issue for our friends around the world.

After continued testing this seems to only occurs when Progressive footage is misidentified as Interlaced.

After continued testing this displacement issue seems to only occurs when Progressive footage is misidentified as Interlaced.

Hi Mary. There are no other effects. . I just past in the Transform data and everything is displaced about 500 pixels down on a 1080 clip. But this ONLY happens when I misidentified a Progressive clip for being a Interlaced clip.
The other issue I mentioned (AE motion blur not working when I paste CP or TF data onto a clip) i think might be more in Adobes court.

You are very welcome Mary.

We know that sometimes interlaced footage has mocha issues, and that sometimes the layer of effects on an AE layer can interfere with our corner pins in AE.
What is the effect layer order on your AE layer? Just to satisfy curiosity.
Cheers,
Mary

Oh, ok. That makes sense. The footage has to be interpreted by mocha properly to get good data out to AE. Thanks for letting us know!
Cheers,
Mary