Power Mesh Not Working In After Effects

Hello,

I am doing a face replacement in Mocha Pro for After Effects. I did this several times and it worked beautifully. I open Mocha within After Effects, then I create a mesh and track it. I save it and go back to After Effects. I copy the Mocha Data from my tracked clip and then paste it to the reference frame which is the face that I need to apply to the clip. I then slick Render, and select Stabilize Warp. The first few times this worked exceptionally.

However, now…it no longer works. I go through the same process, but now it’s like the tack data for the power mesh is not being applied to the reference frame. It says it’s there…when I look and see where I select Render and Stabilize Warp. But then nothing happens. I am at a loss for what is wrong. Is there anyone here who could point me in the right direction?

If you’re not using Mocha Pro 8.0.1 (where we fixed this) and you have a trimmed clip on the timeline, the data can paste off the timeline. Please update to 8.0.1 to get rid of this inconvenient bug and let me know if that fixes your issue.

Cheers,
Mary

I have the exact same problem…it worked before but does not anymore. it is already updated to 8.0.1

Same issue. Very frustrating. Worked through all the tutorial steps. But Stabilize:Warp module is just not sticking to the track. Please help.
Mocha 8.0.3

Read the comment by Ikkyle and I have the same issue. If the clip is trimmed and brought into timeline the power mesh module just does not work. The segment has to be exported out as a self contained clip.

Please address this issue. It’s an unnecessary glitch in an otherwise extraordinary software.

Precomping the source and anything you are putting back into the source is the best workflow right now. Let me make sure we have a user story with @martinb this week.

Please see here for an explanation of what the current problem is:

We are looking into a fix, but there is also another feature coming soon which may help solve many of these problems.

“At present, the only way around this is to precomp your trimmed layer BEFORE you track.
We are looking at finding a way to avoid this automatically by detecting when the footage layer is a precomp, but we’re currently trying to find other solutions as well.”

That doesn’t work either. Nor does bringing in a rendered clip that has been trimmed. I’ve spent hours trying to get this program to work. Very frustrating…

If you can, send me your project and I will take a look:
martinb [at] borisfx.com

I just purchased Mocha pro and was following a Film Riot tutorial on how to use the Mesh Warp for a specific effect.

I have triple-checked and despite following the steps EXACTLY (down to the exact values and keyframes) Mocha Pro fails to track onto, in my case, a face.

I tracked the footage, then precomped the VFX asset I want to track onto the face, then copied the MochaPro effect from my footage and pasted it onto the Pre-Comp and it still doesn’t work, please help!

Did you try precomping the source footage before tracking, as stated above?

Yeah, it took a while but I eventually did that and it worked, thanks!

1 Like