Power Mesh on Face... Hold outs mattes not subtracting

Hi. Wonder if you can help. Had this issue for a while now. Was concentrating on learning After Effects for the last two months so when I came back to it I was getting the same result. Attached is a couple of snapshots. Should the tracking be over the mouth and eyes like this?

The tutorial I was emulating had this…

Did you generate your Mesh before or after you made your eye and mouth holdouts? If you generate them before, the mesh is still there but should not track where the eye masks are, if you generate it after the mesh should not be there at all.

Please let me know.

Cheers,
Mary

Hi Mary, I made the hold outs on the eyes and mouth before I made the face mesh track. Eyes and mouth first, then the face mesh. Another try…

Interesting, I will do some tests. Thank you.

This looks like the same issue I was having. If you create a mesh, move it in layer order and then try and clear and regenerate it, it ignores its layer position in reference to holdout mattes. Here’s a video I made showing the problem. https://we.tl/t-R1U40qRePO

For a work around, if you duplicate the layer and then regenerate the mesh on the duplicated layer it works again.

Hi anglereserve, thanks for taking time out to help. What I could see from your video is that you got the mesh to hold out the person from the very beginning and at the end it resorts to what I’m getting right now. Even if I reverse this process I am still getting the same result, even after clearing and regenerating the mesh. I’ve cleared out my cache in Mocha and After Effects too. Still no joy unfortunately. Odds on a bug but where to start other than re-installing the application. OR I’m just not getting it.
Thanks again :+1:

Hi Mary did a few experiments on this. The only way I could avoid the eyes and mouth was to use the add x-spline to layer but there’s no real control.

You can also simply delete the points you don’t want as well. As a workaround for now. I will see what I can figure out with @martinb on this.

Hi Mary, yeah I was using the Edit The Track Mesh tool. It works okay. Just a little concerned that I may have a bug. The tutorial that I was following along on had no issues so it may be my machine. Would it be worth re-installing the programme or do you think that it’s something fixable at your end?
Thanks for your help.
Regards,
Des

I think it might be a bug for sure. That’s why we have to investigate. Thank you for letting us know about it. That is really helpful for our team. I don’t think a reinstall is going to do much to fix this.

No bother Mary. Thanks. Will wait to see what you find out.
Regards
Des :+1:

So there does seem to be a case where generating the mesh before making holdout mattes doesn’t stop the mesh from being created under the masked regions, but for uniform meshes this may also be because there needs to be overlap when “Vertices on spline” is selected.

We’ll flag a bug for the latter issue, but @anglereserve 's workaround is a good way to fix it for the time being.

Hi, this a similar thing to what i’m finding, first I masked out & tracked the sign in this clip to omit it, created another tracking layer for the HGV & put on a mesh, then dragged it underneath but the sign still messes up the mesh,


But if i create the mesh after i drag the layer below, the hold -out sign mask works as expected, no interference

Hi
This is similar to anglereserve but in my case dosen’t work. Thanks anyway :+1:

Hi Martin,
Thanks for the help. Unfortunately, not able to get to do what anglereserve or gid.joiner are able to do.
I didn’t really understand what you meant from your reply. Wouldn’t making the mesh before the cut-outs not create unwanted data? I then decided to test the Automatic over Uniform and the “verticals on spline” not selected…


Thanks again
Regards
Des
ps I created the mesh after bring the layer to the bottom.

What does yours look like when you turn on Show Layer Mattes, are the eyes & mouth cut out?
Just had another go with mine & although i put the mesh on after i placed the layer at the bottom it was affected by the layers above that were supposed to occlude the things passing in front.

Hi
Did another render with mattes on. The snapshots show the changes in the data within the areas that should not be there. I could be just over-thinking this!
Is this what you were getting?

I’m brand new to this, only had Mocha Pro for a couple of wks so learning from others BTW :grin::wink:
Mine shows the top layer cut out, i’ve given up on the mesh at the moment as it was affecting both spline & mesh so concentrating on the spline but whatever i do i can’t get the top layer to not interact with the layer i’m tracking, it feels like i’ll get a Doh! moment any time soon but till then i haven’t a clue what i’m doing wrong, I created the HGV track first, then i tried creating the occluding track first, moving them up n down the list in different orders, clear cache, i’ve just cleaned PC & restarted :man_shrugging::man_shrugging::thinking:
I’m sure it’s just one little procedure i’m getting wrong,