Powermesh not tracking

I am new to Mocha pro. I am on a trial period. Mainly for the powermesh option.

I have tried many a tutorial from youtube, including Boris own. I have followed them all to a T.

Some slightly differ based on precomposing tracks, but essentially the all boil down to clicking ‘render’, ‘module and stabilize warp’ then finally ‘apply matte’.

Despite all this, my overlayed image does not track.

I am trying to put a simple logo over a jumper. The area is tracked, with mesh and perspective. Then planar surface expanded, mesh warp and high quality. Saved and exit.

I then insert my image in to ae. I have tried precomposing and not precomposing. I copy the data from mocha from the original file on to the inserted image. Then apply the steps as mentioned above.

According to The guys at Mocha support, I may be missing a step and directed me here.

Can you help?This thing is going through the window!

OS Mac and AE cc 2022

Can I see what the shot looks like? If you can’t share here, please email MaryP at BorisFX.com and I will take a look. It’s hard to know from your description what is going on.