Pre comp Won't launch Mocha Pro

Hello, I have 360 degree footage, I applied VR converter, input Equirectangular, output Cube Map

I precomped & moved all attributes

I applied Mocha Pro to the pre comp, clicked launch, the box starts up, Mocha Pro starting, then nothing happens. I need to camera solve a 360 degree shot.

Thank you in advance

If you apply Mocha AE and try to launch that instead, does that launch?
What system are you on and which version of Mocha?
Can you please provide your Mocha log? I can tell you where to locate the log once I know which system you’re on.

A failure to launch is usually a fundamental system issue such as:

  • Mocha can’t initialize the GPU
  • A drive cache path is missing or is write-protected

Hi Martin,

I applied Mocha AE and it didn’t open. It does open when it’s the base original layer. I tested precomping the base layer with no effects, then applying VR converter to the precomp, then applying Mocha Pro & that worked & it opened, but it opened looking at the source file not with the applied VR converter on there. Could there be an issue with VR Converter perhaps?

I’m on After Effects v22.6 the latest version.

I just subscribed to a year subscription of Mocha Pro

I’m on Windows 10, x64 bit, 3090 GPU, AMD Ryzen 3970X 32-core CPU, 128 GB Ram, using SSDs, my GPU drivers are up to date.

I can’t see why VR converter would be a problem, since the Precomp essentially pre-renders it. I just tried myself and the precomp seems fine.

Just so i’m clear here: It sounds as though you converted this to a cube map before importing to Mocha. Can you show me your settings here and a screen shot of your setup?

Even if we can figure out why the Mocha UI isn’t opening, I doubt you can solve the shot this way. Mocha doesn’t know anything about cube maps, so the camera solver will only work if you can make sure all the necessary motion is in one face of the cube. At which point you might as well use a rectilinear projection instead, which will be much easier to work with in Mocha.

You can use another instance of Mocha Pro to extract the rectilinear frame by setting the render mode to lens: undistort then adjusting the lat/long/fov as needed.