Premiere now freezes when loading and says it can not load Bcc Plugins

Premiere now freezes when loading and says it can not load Bcc Plugins. I have been using continuum for months with no problems. I updated the plugins today…and premiere worked once…then no more. All of my other premiere projects, that I do not actually use the plugins on video clips,…open fine.

Sounds like you may have encountered a bug that was newly introduced with the latest update to Premiere Pro, which happened last week. The best way forward right now is for you to temporarily step back to the previous version of Premiere until this issue has been fixed, either by us or by Adobe.


Thank you

I’m experiencing this issue as well.

Does anyone know what is the latest version of Premiere we are able to use and still open projects using bcc effects?


For now, we recommend using Premiere Pro 2023.0, which does not exhibit this issue - the issue is apparent in the PP 2023.1 update. Please know that we are working closely with the Adobe team to resolve this issue as quickly as possible.


Wow, what a mess!!! I used the BCC Beauty filter in a project and everything was fine. Then out of the blue today I couldn’t load my project. I figured with all the updates it was time to do a clean install and jump from Windows 10 Pro to 11 Pro. Rebuild entire system and ran all updates from adobe and Boris. Still can’t load the project. Just uninstalled all Boris effects and it looks like it is going to load. It has been 7 hours of hell with a client expecting approval copies tomorrow morning. Guess I can’t use the Beauty filter on the ladies. PLEASE fix this and fix it fast.

I think I found a work around. I’ve noticed it with flash that there are missing effects so I loaded a basic project and applied an effect. Then I have loaded my big project with all the effects and I think it is now loading OK. I think it is a problem with a large project being the first one opened with the effects and the software trying to check the license. I’ll keep trouble shooting. Ask my in a couple days if I’m still alive and have a job.

Hi Nathan,

There is an issue with Premiere Pro 2023.1 and Continuum in that reloading timelines that have used Continuum will in most cases result in a crash. The temporary workaround is to use Premiere Pro 2023.0, as this combination does not exhibit this issue.

We have a fix for the issue that we’ve been testing in our labs and we’re fairly confident that we’ll be able to release it very soon. If you would like to test it on your system prior to release please reach out to me directly. You can find me at peterm(at)borisfx(dot)com.


This moring I am up and my little trick of opening a small project with an effect applied is working so far. Then I can open my huge project and work on it. I would love to beta test when you think you have a fix.

New Reabuild last night:
Windows 11 Pro
All Adobe and BCC products are current

Motherboard - Rog Zenith II Extreme Alpha
Processor AMD Ryzen Threadripper 3990X 64 Core 2.90 GHz
128 Gig Ram
4GB SanDisk SSD
Project Drives are all SanDisk SSD via USBC 10 connections
Video Card NVIDIA GeForce RTX 3090
Processor Fans - ROG Strix LC 360 White Edition

Hi Nathan,

We’ve decided to release the updated build of Continuum that we’ve been testing which includes a fix for the issue in Premiere Pro - it should be available for download later today.



This was working fine after your guys update and was even working for awhile in premiere 23.2.

But it started happening again today for some reason. And this time it is occurring entirely at random.

Now I can open a project and have it work. Add effects, and everything appears to be fine. Except for the time it decides it doesn’t want to work. This can be after several changes with new effects added. Or even just opening and closing a project for review. The next time I try to open the project it does that freeze and crash thing as before.

I got one update this morning from adobe. Creative cloud and photoshop. Not sure how those would affect premiere and boris. But it happened around the same time. So maybe related.

I’ll try reverting back to 23.0 and see it that works for now.


Hi Peter, I have the Same issue, I think it happens with the BCC Brightness & Contrast.

This worked for me.