Premiere Pro | Mocha Pro | Insert Module | Insert Layer not rendering text

Windows 10 - Premiere Pro 15 - Mocha Pro 2021

I am able to use insert module with an imported image,

but it doesn’t work with a Premiere Pro graphic clip such as text, and using “Insert Layer” option.

I have video clip on V1 and graphic clip on V2.

image

image

I have also tried switching the graphic layer to V1 and video to V2, with the Insert Layer set to V1, but still not working.

Is this a known issue with Premiere Pro graphic layers in Mocha ?

Any alternative methods if it is ?

Generally, it only works with footage layers, but try nesting the graphics layer.
This should essentially convert it to a footage layer so it can be read.

Yikes, that’s so unintuitive, but thank you so much for the solution.

It is, but since graphics layers are essentially effects applied to an alpha layer they are not directly rendered so Mocha cannot read in the same manner as footage.
Nesting essentially prerenders the effect to pixels so they can be read.
In After Effects most layers can be read, but sometimes you have to PreComp them (pretty much the same thing as nesting in Premiere) in order for the combined effects to be read correctly.

Martin it is so informative of you to spend your time explaining the technical reasons for requiring a user to nest a graphic layer in Premiere Pro before applying a subsequent Mocha plugin.

I expect it’s one of the reasons I will return to Avid, since I seem to waste a lot of time on delving into this host’s quirks.

I suppose it’s not possible to write the plugin such that it automatically nests a detected graphic layer so that the user doesn’t have to.

In terms of automatically interpreting the graphical layers, I’m not sure. I’ll ask the dev team and see what they think.

1 Like