Premiere Random Crashes

I’ve been having Premiere do ‘unexpected quits’ while working with Mocha. Usually during final output rendering but at times just while editing. Only happens when I have Mocha applied to a clip. I have a sequence with about 20 insert composite clips (each only about 5 seconds) in it and couldn’t get it to final render. So I rendered it one clip at a time. Sometimes it would quit, I would restart PPro and try again and it would work. Then the next 2 would be fine and then quit again. There seemed to be no pattern for which clip would cause the crash because it would be fine the next time I tried to render it.

This has been on on-going problem. I seem to have better luck inside After Effects than Premiere.

I was finally able to export my sequence by rendering one clip at a time (restating after every crash) and rebuilding the sequence from the 25 rendered individual clips. But that’s kind of a bummer work-around.

Mac Pro 2010 (12 core)
32 gigs RAM
MacOS 10.13.6
Radeon 7950 Mac Edition with 3 gigs vram
Premiere 2020
Mocha Pro 6.0.2

Any tips on creating a more stable system would be greatly appreciated.

I see you’re using a previous version of Mocha Pro, I would suggest downloading a trial of the latest version of Mocha Pro and seeing if the crashes continue (it will render with a watermark). We have made some progress with this issue inside of premiere, and I’d be curious to see if this issue continues with our latest release.

Can you try that and let me know?

Cheers,
Mary

Hi Mary.

2 questions:

  1. If I download the trial and it still doesn’t fix the problem, what’s the process of downgrading back to my paid older version?

  2. I checked to see how much the upgrade is and it will only allow me to pay for 2 licenses. I think I have mocha running on my laptop as well but I really don’t need the latest features on both machines. How can I only buy one license?

All you’d have to do is go to legacy downloads and reinstall your software from there. You may want to deactivate the license before you uninstall and reactivate it when you reinstall.

If you’re only getting the option to upgrade two instead of one I might need to get you in touch with sales.

But let’s see if this works or not first.

Cheers,
Mary

I was looking for an excuse to upgrade it anyway…

Sadly, it didn’t fix it. But I will say the new version does feel snappier.

Any other suggestions?

Yes, can you send me your crash file to maryp@borisfx.com if you have one? Or any error message you are getting. Basically, any clues you can give us will help us figure out the issue.

I will say, I have noticed the AE renderer to be a bit more forgiving than the Premiere one, so this might be a video card resource problem still. Not everything is optimized for those radeon cards as well, and that could be a contributing factor.

Cheers,
Mary