Primatte studio hair shimmering

No matter what I apply, I can’t seem to get my subject’s hair from having an artifact-shimmering effect. I’ve blurred, softened… either it looks too compressed or it shimmers… please help

for more info. This is a clip shot the same as many other clips… same lighting to green screen and subject where the chroma key has worked fine… but for some reason, this clip, the software is behaving differently

Can you send a sample clip, either publicly or directly to me offline if you would prefer - jclement at borisfx dot com

You’ve had similar issues with some clips in the past, and if I recall the issue was at least partially the result of significant compression artifacts in the clip. Chroma keying source clips should ideally be as free of compression damage as possible.

this was shot in 4k,
here you go :slight_smile:

I uploaded the video clip, but don’t see it… do you have a size limit? it’s 1/2 a gig

emailed you an upload to the video :slight_smile:

hello, hello?


From the video link you emailed it looks like the clip must have a significant amount of spill combined perhaps with sensor noise and compression artifacts, but it is difficult to tell for sure. Can you send the original clip prior to any effect?

If you have Continuum 2019.5 there is a new Spill Suppression option which is integrated into Primatte Studio and also available as a separate effect on its own. This newer, more robust spill suppression option lets you focus the core keying more on getting a clean alpha channel and worry less about spill regions.


The subject is over 10 feet away from the green screen, so I’m not sure that spill could be an issue… will upload before adding primatte, which is the only effect added

Hi Jason;
just sent you the undressed footage… look forward to hearing from you :slight_smile:


There is a lot of colored noise in this shot which, when combined with wispy blond hair, is going to make it difficult. If you zoom way in on the the model’s hair and look at the individual pixels you will see lots of red/green/blue tinted pixels due to noise in the original shot. When there are greenish noise pixels in the hair that are similar in color the green screen color it will be difficult to get a really clean key. That being said, the final key shot you sent seems to show more noise than I observed in my experiments. I have attached a sample preset which you could try loading to see if it helps you get (2.4 KB) Try using the Primatte Background and Foreground Cleanup tools to eliminate more of the holes in the interior of the hair. That will minimize the chatter to just the regions right around the edges. I would suggest following some of the tutorial and webinar videos on our website to learn more about dialing in a key with Primatte Studio. Then after getting a better initial key you can experiment with Primatte Studio’s Matte Refinement tools to minimize the remaining noise. Pre-applying BCC Noise Reduction might also help.

thank you Jason… adding the BCC Noise Reduction first made all the difference :slight_smile:

and your file worked perfectly… thank you so much for all your help :slight_smile:

Glad to hear that worked for you!