Primatte Studio HUD drawing issue

I’m working in Resolve 17, OS 10.15.7 on the fusion page. The BCC Primatte plugin HUD is exhibiting a drawing problem.

Secondarily, on the fusion page, when I put an external clip on the page, the frames do not appear in the viewer. Of course, this is is a question for the Black Magic forum but thought I’d drop it in here in case anyone else has seen the problem.


Unfortunately Continuum isn’t supported in Fusion, either standalone or in Resolve, which is why you’re seeing that result. We suggest using Primatte in either he color or edit tab.


Hi Peter,
Ok I’ll give that a shot. Is this expected to change in the future?

Hi Blake,

We’ve had that on our list for a while now but it has been leapfrogged by other feature work. I’ll add your vote to the ticket to help push it up in the queue but I doubt that it would happen during this release cycle.


Copy, thx.

Last question. I have an older computer with only 2GB VRAM and BCC 2021. Would BCC+ filters work better on my system? I’m seeing lots of spinning beach balls using primatte on the color page.

Hmmm … that’s not a lot of VRAM for VFX processing. The BCC filters use a mix of OpenGL, OpenCL and CPU for rendering, while the BCC+ filters use OpenCL with a CPU fallback should the GPU fail or become unavailable. Hard to say whether one will perform better than another with so little VRAM.


Thanks for the response. Yes, we’re due for an upgrade but need to get through this one project first. Does the older BCC use any CPU processing or is it all VRAM?

All discussion of versions and processing aside…

I’m now using Primatte Studio on the color page. I reviewed the training video on how to setup Primatte for use in Resolve. The final composite is not working. The matte looks good in the viewer and I have an alpha channel passing through to Resolve with the node set to use ofx alpha.

Compositing problem solved. Resolve was not caching the frames correctly. Strangely, clearing the playback cache did not fix the problem. I had to remove a clip and replace it on the timeline, then reload the plugins.

Wow - that’s an obscure little bug and clearly on the Resolve side of things. Probably not a bad idea to reach out to let them know about that. Thanks for sharing this with us.

In response to your question about the cpu/gpu processing with the legacy BCC (non BCC+) filters - most, but not all, of the legacy BCC filters include a CPU fallback. BCC filters can be switched to CPU mode by clicking on the cog wheel in the filter banner and unchecking the Enable OpenCL checkbox.

Note that this is a “sticky” preference item meaning that it will affect all new instances of all legacy BCC filters going forward. You must manually re-enable the Enable OpenCL checkbox in order to return to GPU processing.

Just be aware that (1) CPU processing is much slower than CPU processing so performance will drop and (2) there are some filters that will render black as a result of the switch due to not having a CPU path, so if you encounter a situation where the filter is rendering black frames you will need to return to GPU processing.

I hope this helps.

Copy that. Thanks for the detailed answer.