Problem with dual video card laptop and Optics

This is not exactly a Boris Fx problem, but perhaps one of you has already solved the same frustration: I use optics as a plugin for photoshop 2020 on a dell laptop with an nvidia GTX 1050 and intel graphics 630, lots of RAM and scratch disk space. I use Optics a lot - as a plugin to Photoshop cc 2020. All drivers up to date with latest Nvidia studio version. Since the last windows 64 bit, 10 home) update and BIOS flashing, unfortunately same day, The only way I can use Optics is to disable the intel graphics, which makes operations slow and the mouse jerky. As far as I can tell, All of the photoshop, windows, and nvidia settings all have preferences for nvidia for high def video. What might I be missing?? Thanks.

You should not have to disable your Intel graphics card. Can you right-click on your desktop, go to NVIDIA Control Panel, Manage 3D Settings, and set your preferred graphics processor to “high-performance NVIDIA processor”? Does that make a difference for you?

Thanks but I did that and on the programs tab, I specifically identified and added photoshop.exe

Does enabling “high-performance NVIDIA processor” for Optics.exe help?

Windows 10 has also started adding controls that appear to override the Nvidia control panel.

Click on the finder/magnifying glass in the taskbar and type in “gpu” and select the “graphics settings” app.

You can then select Optics in the Desktop App list and tell it to use the High Performance setting which means it should prefer the Nvidia gpu rather than Intel.

Thank you Marco and Michael. Brilliant (and in retrospect, embarrassingly obvious). I added optics.exe to both places, and voila, all seems good. If either of you can ever use anything from visualjason.com, just e-mail me from any page there.
Sincerely,
Jason

The problem is back again. There have been some restarts. windows gpu and nvidia hi performance settings and photoshop performance preferences are all the same. Optics works OK but when I go back to photoshop I get a white viewing pane. If I try to save the work, it goes into a very, very slow or endless loop.

After a Windows 10 update, the graphics driver normally needs to be updated from the manufacturer’s website. Otherwise, you can encounter the white screen you are experiencing. If you have already updated your graphics driver, can you try the following:

  • Run Optics
  • Select File > Preferences
  • Change GPU Rendering from Enabled to Disabled
  • Click OK

Does Optics run as expected now?

No, That did not work. Do you think it makes any difference to use the Nvidia game ready driver vs the studio one?

OK, please make sure you set the Optics GPU Rendering preference back to Enabled.

NVIDIA Studio Drivers provide the best performance and reliability when working with creative applications like Photoshop. I would go with that one.