Problem with Mocha Hitfilm


#1

I just bought hitfilm 4 pro and was trying to use mocha but when I clicked the “Solve With Mocha Hitfilm” button, I kept getting this error “Warning: Cannot connect to the MediaIOserver; QuickTime will not be available.” I didn’t know what this meant so I clicked ok and tried to open an MP4 file and got an error saying the format wasn’t supported. I have the newest version of quick time installed and I’m running on a 64-bit hp envy laptop.


#2

Hi there,

It sounds like you need to restart your machine and make sure the MediaIOserver service is running before you start mocha. It sometimes takes a minute to start up, or sometimes starts with errors. If it is corrupt, you may need to reinstall your software.

Please let me know if you have any more questions and I will be happy to help you.

Cheers,
Mary


#3

Hi, thanks for the reply I tried to run MediaIOserver but got an error saying “The application has failed to start because it’s side by side configuration is incorrect.”


#4

It may be that you have some Library problems on your machine. Try a full uninstall and re-install of mocha, since it’s mocha hitfilm, you will probably need to uninstall HitFlm to reinstall the mocha that is packaged with HitFilm. But it’s important to clean up your library files and see if this fixes it.

  • Uninstall your mocha software.
  • Find any Preferences (or .plist) files:
    • On pre-mavericks MAC this will be under /Users/*YOURUSERNAME*/Library/Preferences/
    • On Windows, open the command prompt as an administrator, type regedit in the window, and hit enter. Navigate to HKEY_CURRENT_USER/Software/Imagineer Systems Ltd/mocha
  • Delete your preferences files:
    • On pre-mavericks MAC Delete the files that begin with com.imagineersystems.mocha
    • On Windows, Delete the contents of any folder in HKEY_CURRENT_USER/Software/Imagineer Systems Ltd/mocha
  • Re-install the software from scratch by downloading a new mocha installer off of our downloads section.
  • If you are on Mavericks, you will need to try something else to delete your preferences because you will not be able to access and delete your .plist files the way you can on older systems. You may try one of the following techniques:
    • Use friendly solution:
      • Quit the app, and make sure it is not set to run at login.
      • Delete the app’s prefs file (typically in ~/Library/Preferences/Imagineer Systems Ltd/mocha.
      • Logout.
      • Login.
      • Launch the app. Follow mocha’s instructions to reset preferences.
    • Preferred solution:
      • Quit the app.
      • Open Terminal, paste the following, and press Return:
        defaults delete com.imagineersystems.*.plist
      • Launch the app. Follow mocha’s instructions to reset preferences.

#5

So to be clear you want Me to uninstall hitfilm and reinstall it


#6

Yes. But the more important thing is to uninstall and then clean up those files, then reinstall it.


#7

Thank you I’ll update after I do all that.


#8

So now that I’ve done all that do I need to run MediaIOserver before I start mocha.


#9

I tried to run MediaIOserver again and got the same error.


#10

OK, can you send me an email to maryp@imagineersystems.com with the best number to reach you at?

Cheers,
Mary


#11

Could it be that I need an older version of Quicktime, or maybe I’m supposed to have another program running before I run MediaIOserver.


#12

I actually found the problem, I was missing some versions of Microsoft visual c++, so I went to Microsoft.com and downloaded all of them.


#13

Good to know, usually it’s a corrupt install but I am glad that there’s an alternative to look out for! Thank you for the update!

Cheers,
Mary


#14

I have the same problem with the MediaIOServer error I tried deleting the files and re downloading it and installing new visual c++ like the last guy but haven’t had any luck


#15

Usually just restarting your machine and waiting a moment for all your processes to load also fixes this, it’s usually caused from Quicktime needing a minute to load. If users have security concerns and do not want to use Quicktime on Windows, but still want access to .MOV and .MP4 codecs, we recommend that they uninstall QuickTime Player, and install only the QuickTime Essentials part of the package. This substantially reduces the attack surface and reduces QuickTime to the status of a faceless library on their system which will only be used inside of other software for codec decoding. For v5 users, the mocha Pro 5 Plug-in option is the ideal solution because it has no dependency on QuickTime and reads the image data right out of the host’s timeline. For users who are unable to upgrade to mocha Pro 5 the Plug-in, installing the codecs alone will help solve some of the problems users are encountering with Quicktime on Windows.

If you have trouble installing only the quicktime essentials, try this method:

  1. Fully uninstall Quicktime and delete any Apple folders left on your machine for a clean uninstall.
  2. Reinstall using the full installation option with the player installed as well.
  3. In your program management configuration panel, select the uninstall option and ask Quicktime to be “modified.”
  4. Uninstall Quicktime Player only but keep the full library of codecs you need to read .MP4 and .MOV files.

#16

Hi Mary,

The important thing is that we don’t want that error message to appear (it STILL appears in the plug-in) every time. We know we don’t want QT in Windows and have already made that decision.

Very annyoying-especially in a brand new piece of software.

Thanks!

Lance


#17

Hi Lance,

The issue is that mocha is built with the Quicktime engine in mind, so even if you don’t want to use it, you still need the codecs but not the install of quicktime itself. We are moving away from that engine in the future, but it’s not something that can be fixed with this version. You do not have to have quicktime installed, but you’re going to want to install the codecs or you’re going to run into this issue.

Hope that helps,
Mary


#18

Hello Mary,

Just bought HitFilm 2017 which has mocha 5.1.1 and on launch I get the MediaIOServer warning and that Quicktime wont be available. I say good as I don’t want it but could we get a “thanks but don’t notify me again” tick box please?

Also you mentioned this before
For v5 users, the mocha Pro 5 Plug-in option is the ideal solution because it has no dependency on QuickTime and reads the image data right out of the host’s timeline.

PS I am running this on windows 10 64bit anniversary edition


#19

Mocha in hitfilm is not the plugin, it’s a standalone, and so needs quicktime. But also the codecs are not the same as the full quicktime engine install, and it should work without the full quicktime engine install.


#20

It does seem to work just need to click ok to continue.
Love the Mocha (and only just starting to learn how to use it) and was one of the core reasons I bought hitfilm 2017.

Do think about the suggestion to add ignore error option so people don’t have to get reminded of something they already know.
Now back to watching mocha tutorials for me so I can start working out what I’m doing :wink: