Problems with 3D camera export

Hi everyone.
So I’ve been trying out the new 3D camera tracking in V3. I’ve followed a couple of tutorials and think I know what I’m doing.
I’ve got a scene that’s looking down a hallway. It’s hand held but basically a pan,tilt zoom shot. I’ve added five planer tracks on co planer regions.
I’ve made them quite large to make sure I get good tracks. The tracks cover the whole shot, which is only 100 frames long with a couple of black frames at the end.
I make sure to tell the tracks not to track those last couple of frames.
It’s when I get to the camera solve that I run into issues.
The first issue is that I can’t seem to get Mocha to accept any camera mode other than Auto. Whenever I try to export using say large parallax I get this error “Camera will be solved only for frames 1 to 97. Select more layers to get the solution for a wider frame range”
Which is fine because the last 3 frames are black. But it doesn’t then go on to then solve.
So I use auto which works but when I import the fbx into Maya I find the camera is moving all over the place and doesn’t represent what the original camera did at all!
Any help with this would be greatly appreciated. I can also upload the original file if that’s any help? It does seem to be quite low quality in terms of codec so I’m wondering if this is the problem.
Look forward to hearing your thoughts.
Peter

Hi there,

Try trimming the black frames out in the timeline (you can easily set in and out points in the timeline) and see if that helps you.

And PTZ won’t solve a handheld shot, no matter how steady your hand is. So you need two non-co-planar planes that are tracked through the entire shot to make Large Parralax work, so a floor and a wall but not two planes on the wall.

Align the surface tools to the areas of the floor and wall that look like they match the geometry, this will put your nulls in useful places for your shot.

Without seeing the shot, that’s my best advice. Try that first and then if you continue to have issues, you are welcome to send me the shot and I will see if I can figure out what is going wrong.

Cheers,
Mary

OK, the only thing I can think of is the planar track itself is slipping. Check and make sure moving shadows aren’t throwing the track off by turning the grid and surface on as you track and making sure they are locked onto the walls.

And thanks about the tutorial!

Cheers,
Mary

—Quote—
So I tried auto again which seemed a lot better. It told me it had an 85% accurate solve, which if I remember correctly is still pretty good. I think it was mentioned that anything below 80% could cause noticeable problems?
—End Quote—
OK, an 85% should be pretty good, anything above 70% is considered a decent solve.
—Quote—
In one of the solves I did, when I exported into Maya I found that the nulls would move around as well as the camera. Is this normal, as personally I’d like it if the nulls stayed stationary as it will make it easier to animate to. Saying that the latest export I did only had the camera moving, so not sure why some of my earlier attempts moved the nulls as well?
—End Quote—
The nulls should be stationary, it sounds like the footage isn’t lining up.
—Quote—
Although my latest track seems pretty solid, in that I can place a 3D cube in the scene and it seems to stick to the part of the footage I want it to. The actual grid still seems to move slightly differently to the camera. I have no idea how this could work, as surely if the grid isn’t sticking then any 3D object I place wouldn’t stick either?
—End Quote—
The camera solve is solving for planes, so the grid might not line up perfectly in other areas of the shot, but will line up for the nulls you have in the scene.
You can not have different frame rates, aspect ratios, or film sizes from mocha to maya and expect the shot to line up. If it’s 24 fps in mocha, it must be 24fps in maya. You may be experiencing shot misalignment due to the settings in maya not matching the settings in mocha.
I am happy to go over this shot with you on skype though anytime between 9:00am PST and 6:00pm PST.
Cheers,
Mary

OK, the only thing I can think of is the planar track itself is slipping. Check and make sure moving shadows aren’t throwing the track off by turning the grid and surface on as you track and making sure they are locked onto the walls.
And thanks about the tutorial!
Cheers,
Mary

Hi there,
Try trimming the black frames out in the timeline (you can easily set in and out points in the timeline) and see if that helps you.
And PTZ won’t solve a handheld shot, no matter how steady your hand is. So you need two non-co-planar planes that are tracked through the entire shot to make Large Parralax work, so a floor and a wall but not two planes on the wall.
Align the surface tools to the areas of the floor and wall that look like they match the geometry, this will put your nulls in useful places for your shot.
Without seeing the shot, that’s my best advice. Try that first and then if you continue to have issues, you are welcome to send me the shot and I will see if I can figure out what is going wrong.
Cheers,
Mary

—Quote—
So I tried auto again which seemed a lot better. It told me it had an 85% accurate solve, which if I remember correctly is still pretty good. I think it was mentioned that anything below 80% could cause noticeable problems?
—End Quote—
OK, an 85% should be pretty good, anything above 70% is considered a decent solve.

—Quote—
In one of the solves I did, when I exported into Maya I found that the nulls would move around as well as the camera. Is this normal, as personally I’d like it if the nulls stayed stationary as it will make it easier to animate to. Saying that the latest export I did only had the camera moving, so not sure why some of my earlier attempts moved the nulls as well?
—End Quote—
The nulls should be stationary, it sounds like the footage isn’t lining up.

—Quote—
Although my latest track seems pretty solid, in that I can place a 3D cube in the scene and it seems to stick to the part of the footage I want it to. The actual grid still seems to move slightly differently to the camera. I have no idea how this could work, as surely if the grid isn’t sticking then any 3D object I place wouldn’t stick either?
—End Quote—
The camera solve is solving for planes, so the grid might not line up perfectly in other areas of the shot, but will line up for the nulls you have in the scene.

You can not have different frame rates, aspect ratios, or film sizes from mocha to maya and expect the shot to line up. If it’s 24 fps in mocha, it must be 24fps in maya. You may be experiencing shot misalignment due to the settings in maya not matching the settings in mocha.

I am happy to go over this shot with you on skype though anytime between 9:00am PST and 6:00pm PST.

Cheers,
Mary

You can use nulls based on the same planar track, so, if the nulls are rock solid in mocha and the track is as well, just line another layer to the floor and hook it up to the floor track and use that as another set of nulls to export. You can do that as many times as you like.
Don’t ever assume the settings line up, check them manually. :slight_smile:
Also, like everything that gets exported out of mocha, make sure you as importing the data on the FIRST FRAME of the shot. The first frame in mocha and maya will need to line up exactly.
Cheers,
Mary

You can use nulls based on the same planar track, so, if the nulls are rock solid in mocha and the track is as well, just line another layer to the floor and hook it up to the floor track and use that as another set of nulls to export. You can do that as many times as you like.

Don’t ever assume the settings line up, check them manually. :slight_smile:

Also, like everything that gets exported out of mocha, make sure you as importing the data on the FIRST FRAME of the shot. The first frame in mocha and maya will need to line up exactly.

Cheers,
Mary

Hi Mary,

Thanks for the quick reply and solid answers.

The tracking lining up with the nulls makes sense now as I tried to add another 3D object to sit on an area of the image that I hadn’t tracked and it didn’t match well at all. So I’m guessing that if I want to place an object in some area of the screen I need to make sure that I have nulls tracked in that area?

I thought that Mocha exported a camera based on the settings that it had on the imported footage. It seems to bring in focal distance data so I’d assumed that the aspect ration of the FBX camera would be the same.

I’ll go over all the settings and make sure what I have is set up right. But yes if I’m still getting issues it would be good to skype. I’ll let you know how I get on.

Thanks again.

Peter

Hi everyone.

So I’ve been trying out the new 3D camera tracking in V3. I’ve followed a couple of tutorials and think I know what I’m doing.

I’ve got a scene that’s looking down a hallway. It’s hand held but basically a pan,tilt zoom shot. I’ve added five planer tracks on co planer regions.
I’ve made them quite large to make sure I get good tracks. The tracks cover the whole shot, which is only 100 frames long with a couple of black frames at the end.
I make sure to tell the tracks not to track those last couple of frames.

It’s when I get to the camera solve that I run into issues.

The first issue is that I can’t seem to get Mocha to accept any camera mode other than Auto. Whenever I try to export using say large parallax I get this error “Camera will be solved only for frames 1 to 97. Select more layers to get the solution for a wider frame range”
Which is fine because the last 3 frames are black. But it doesn’t then go on to then solve.

So I use auto which works but when I import the fbx into Maya I find the camera is moving all over the place and doesn’t represent what the original camera did at all!

Any help with this would be greatly appreciated. I can also upload the original file if that’s any help? It does seem to be quite low quality in terms of codec so I’m wondering if this is the problem.

Look forward to hearing your thoughts.

Peter

Hi Mary,
Thanks for the advice, I’ll try those tips. I have a feeling the footage isn’t helping as it took me a while to find areas that would track well. I don’t know why Mocha doesn’t seem to like the footage that much. Apart from being a little grainy (which I blurred slightly to help) there doesn’t seem to be any real reason why it wouldn’t track.
The tracking areas I used were all perpendicular to the camera as I found the walls and door that extend away from the camera just wouldn’t track without drifting and jittering,
I’ll let you know how I get on.
Great tutorial on 3D tracking by the way, I thoroughly enjoyed it.
Many thanks
Peter

Hi Mary,

Thanks for the advice, I’ll try those tips. I have a feeling the footage isn’t helping as it took me a while to find areas that would track well. I don’t know why Mocha doesn’t seem to like the footage that much. Apart from being a little grainy (which I blurred slightly to help) there doesn’t seem to be any real reason why it wouldn’t track.

The tracking areas I used were all perpendicular to the camera as I found the walls and door that extend away from the camera just wouldn’t track without drifting and jittering,

I’ll let you know how I get on.

Great tutorial on 3D tracking by the way, I thoroughly enjoyed it.

Many thanks

Peter

Hi Mary,

Yeah I made sure I had the grid on when I was testing the tracks. I think one has a very, very slight slip at the beginning but nothing that I would have thought would cause any issues.

I did what you said and got rid of the black frames at the end. That solved the problem of it not wanting to solve using the large parallax.
But when I did do a solve with the large parallax I found the camera was really erratic in Maya.
So I tried auto again which seemed a lot better. It told me it had an 85% accurate solve, which if I remember correctly is still pretty good. I think it was mentioned that anything below 80% could cause noticeable problems?

I loaded this into Maya. One thing I changed other than the frame rate was the unit size. Maya defaults to CM but I think it needs to be set to Metres for Mocha? So I set it to Metres and that seemed to get a much more accurate result.

A couple of things that are still confusing me.

In one of the solves I did, when I exported into Maya I found that the nulls would move around as well as the camera. Is this normal, as personally I’d like it if the nulls stayed stationary as it will make it easier to animate to.
Saying that the latest export I did only had the camera moving, so not sure why some of my earlier attempts moved the nulls as well?

Although my latest track seems pretty solid, in that I can place a 3D cube in the scene and it seems to stick to the part of the footage I want it to. The actual grid still seems to move slightly differently to the camera. I have no idea how this could work, as surely if the grid isn’t sticking then any 3D object I place wouldn’t stick either?

Like I said, it works and as long as the final result looks good I don’t really care but it would be nice to know the answer to the above questions for any similar problems I may encounter along the way.

Again, many thanks for your help.

Peter

Hi Mary,
Yeah I made sure I had the grid on when I was testing the tracks. I think one has a very, very slight slip at the beginning but nothing that I would have thought would cause any issues.
I did what you said and got rid of the black frames at the end. That solved the problem of it not wanting to solve using the large parallax.
But when I did do a solve with the large parallax I found the camera was really erratic in Maya.
So I tried auto again which seemed a lot better. It told me it had an 85% accurate solve, which if I remember correctly is still pretty good. I think it was mentioned that anything below 80% could cause noticeable problems?
I loaded this into Maya. One thing I changed other than the frame rate was the unit size. Maya defaults to CM but I think it needs to be set to Metres for Mocha? So I set it to Metres and that seemed to get a much more accurate result.
A couple of things that are still confusing me.
In one of the solves I did, when I exported into Maya I found that the nulls would move around as well as the camera. Is this normal, as personally I’d like it if the nulls stayed stationary as it will make it easier to animate to.
Saying that the latest export I did only had the camera moving, so not sure why some of my earlier attempts moved the nulls as well?
Although my latest track seems pretty solid, in that I can place a 3D cube in the scene and it seems to stick to the part of the footage I want it to. The actual grid still seems to move slightly differently to the camera. I have no idea how this could work, as surely if the grid isn’t sticking then any 3D object I place wouldn’t stick either?
Like I said, it works and as long as the final result looks good I don’t really care but it would be nice to know the answer to the above questions for any similar problems I may encounter along the way.
Again, many thanks for your help.
Peter

Hi Mary,
Thanks for the quick reply and solid answers.
The tracking lining up with the nulls makes sense now as I tried to add another 3D object to sit on an area of the image that I hadn’t tracked and it didn’t match well at all. So I’m guessing that if I want to place an object in some area of the screen I need to make sure that I have nulls tracked in that area?
I thought that Mocha exported a camera based on the settings that it had on the imported footage. It seems to bring in focal distance data so I’d assumed that the aspect ration of the FBX camera would be the same.
I’ll go over all the settings and make sure what I have is set up right. But yes if I’m still getting issues it would be good to skype. I’ll let you know how I get on.
Thanks again.
Peter

Hi Mary,
Never thought about linking another track just for the nulls, that’s good to know.
I double checked the setting, the only slight inconsistency was the film aspect ratio, in Maya it’s set to 1.78 but it’s a 1280 x 720 shot so by my calculation it should be set to 1.77. I changed it but it’s only made a very subtle difference.
Yeah I’m pretty sure it starts on the same frame as the nulls look pretty much locked.
If I could skype that would be great, I’ll send you my skype details.
Peter

Hi Mary,

Never thought about linking another track just for the nulls, that’s good to know.

I double checked the setting, the only slight inconsistency was the film aspect ratio, in Maya it’s set to 1.78 but it’s a 1280 x 720 shot so by my calculation it should be set to 1.77. I changed it but it’s only made a very subtle difference.

Yeah I’m pretty sure it starts on the same frame as the nulls look pretty much locked.

If I could skype that would be great, I’ll send you my skype details.

Peter