Recommended way to restrict the light wrap on a subject

Greetings I have a person’s head that I’m putting a light wrap on but I only want it on part of the head. I then want to further limit the light wrap, using the roto from background wall/window opening.

Should I be creating a roto node first for the region I want the light wrap to stay within, then pass that roto into the light wrap node input, then use a Composite 1 node to input the light wrap node as foreground and the original person’s head as the background, and then send this output to the background of a second Composite node 2 with the wall/window roto as the foreground, or is there another better/recommended way for doing this? Thanks for help on this :slightly_smiling_face:

Also just to mention a problem I’m having, which I think is related to the light wrap. I tried to comp just a small roto circle of the original head on top of Composite 2, using a Composite 3 where the roto circle is foreground and the Composite 2 is background, and I noticed that there’s what looks like a 1 pixel border around the roto circle. I was expecting it to be a perfect blend from the output of Composite 3, and if I add some blur to the roto circle, it does remove the hard 1 pixel circle edge, but it also seems to create a black/empty space around the circle, which now make a weird dark circle on the final head where the roto circle is :frowning:

If I understand correctly, there are a lot of ways to combine roto layers as well as send them into the “Obey matte” input of most nodes.

You can use blend modes if the layers are in the same roto node:

image

Or you can use math composite if you want to combine multiple roto layers and choose Blend.

As far as your 2nd question, is it a premultiplication issue? Possibly ticking unpremultiply in the offending comp will solve?

Best of luck,
Ross

Thanks for the reply Rosss. I see now, how the hooking the output of one roto into the “obey matte” of another roto will work. I’ll take a look into the premulitply settings I have for future reference, but it looks like using the “obey matte” has corrected everything now :+1:t3: thanks again!