Remove black from RGB channels on render

Another “old PI” question. When rendering in the old pIllusion render there was an option under Alpha Channel to “remove Black from RGB channels”. Is that option still included anywhere? Has it been renamed? All info appreciated!

That option does not exist anymore, but with the flexibility of the new compositing methods, it’s probably not needed.

If back in the host you select “Classic” under the compositing section, PI will render directly on the background image as pI3 did – you shouldn’t see any black fringing using this method. If you select “Alpha + Apply Modes” instead and select a compositing mode, you may see some fringing depending on the transfer mode selected.

Alan.

Thanks, Alan! What I am trying to do is isolate an effect on some footage without the background. I’ve tried doing it on a green background and keying the background out but I do get the black fringing. Maybe I’m trying to do something the hard way that can be done an easier way? What I am shooting for is footage that has a transparent background but the emitter is intact. I hope that makes some sort of sense.

Just apply PI to the footage layer. If that won’t work for you, a screengrab might help me understand better.

Hi Alan. I knew I didn’t explain it very well. Let’s say I have a picture of a valley and I want to show a distant campfire. I overlay the campfire emitter onto the valley footage and try to resize it in the emitter parameters but it doesn’t look right. If I could render the campfire, full size, alone on a transparent background then I could place the fire in the valley and manipulate the campfire size with pan/crop or track motion. I have a screengrab and will try to upload it.

I may have figured out what to do. I was trying to resize the emitter solely with the “size” parameter(s) and was not using the “zoom” parameter - which (I think) will achieve the effect I want. I still need to squeeze down the emitter’s box but that’s easy to do. I am still open to any input you’ve got though! Thanks.

Back in the native plugin UI you can change the Composite Style menu to “Alpha + Apply Mode” and it will generate just the particles over transparency which you can then manipulate/resize as desired before doing the final composite - perhaps with a Screen or Add mode. Note that if you change the native Transforms menu to World you then get some basic scale and offset controls you can use to fine tune the placement back in the native UI if that’s easier - as well as the native Particle Properties controls for Zoom/Scale/etc.

Thanks jclement! That is it. In addition to setting it to "Alpha + Apply ", transforms to “World” , and Apply Mode to “Normal”, I then used “Master Scale” under “World Transform” to accomplish the sizing task in a way that works for me. THANK YOU!

I’ve got a similar requirement using Vega Pro 17 and the latest released Continuum where I can’t get rid of the black fringing around some smoke.

I have a need to layer the fx so I can’t apply the fx to the footage.

I can’t remove the fringing no matter how I change the composite style and apply mode. In fact, I don’t see any visual change no matter how I change the apply mode, which seems unexpected to me.

I don’t know if this is a bug with VP or a bug has crept into the latest PI plugin.

I’ve attached a project without video, to save space but you should be able to drop anything in there and see what’s happening.

I can start a new thread if you’d rather I didn’t piggyback this one.

Alpha composite.zip (1.2 MB)

Try this:

ON Track 1 (where you applied the FX), change the Composite Mode from “Source Alpha” to “Lighten”.

I changed the backdrop from a solid yellow to a blue so you can better see the difference.

Here’s what it looked like when set to Source Alpha:

Here’s what it looks like when changed to “Lighten”:

Might not be a perfect solution, but may get you much closer to the result you’re after?
:slight_smile:

@RedRob thank you. At least in this case that worked perfectly. If there’s any difference between the effect on the colored layer and the one on the footage, I can’t see it.

It also means I can use my preferred solution of pre-rendering the fx in PI and dropping it in as another video layer

You’re welcome!

Now if only we could figure out how NOT to get that black part to output from PI, that’d be fantastic! (I’ve had this problem in the past too)

I may have spoken too soon. Once the smoke passed a face, it gave the person a kind of demon look.

I was using a video layer exported from PI.

I’ll have to experiment more in the morning.

Screen gives the least objectionable result but still isn’t quite right.

Makes me wonder what the results are in other apps or if extra compositing would be needed when PI is used with an app that makes better use of the GPU

Hi Michael,

Have you tried rendering from PI using RGB + Straight Alpha? I believe that should provide you with the result that you’re after.

Thanks,
Peter.

@PeterMcAuley I’ve tried all sorts of combinations so far. Here’s a visual summary…

One thing I’ve also encountered is that black isn’t black in the renders from PI. If you look closely next to the snake’s head you’ll see a faint line where the image is darker to the right.

The image is being darkened by both the files from PI. I suspect this is because the file is being generated with video levels and I’ve been able to work around that with other video sources by tweaking the levels with the VP “levels” fx. If I do that here, I get severe haloing.

One further note that might deserve a separate bug report is that choosing the “Alpha + Apply Mode” in the Particle Illusion fx panel within VP appears to do nothing at all regardless of the apply mode chosen.

I’ve uploaded the full project and PI output files to https://dragonseye.com/AlphaComposite.zip 258MB if you’d like to take a look

Hi Michael,

Thanks for posting that image and yep, turns out that Alan understands the problem and has a good idea as to how this might be fixed. It will require some coding.

I’ll ask QA to reproduce the broken apply modes that you mentioned - thanks for the alert to that.

@Alan_Lorence @PeterMcAuley Is there a chance that this could be worked around with a different host, say Resolve, or is this purely something that needs to be tweaked within PI?