Remove mocha pro not tracking

i have spent days on what should be taking an hour. mocha pro removal will work only sometimes. then all of the sudden, it stops tracking in the removal…i have my remove layer that i tracked. then i put in a background layer and link in to the remove layer. and ensure it tracks with the remove layer properly. then i select the remove layer and go to remove section, create…do my photoshop thing, save, and go back to mocho and use that cleanplate and check exclusive box. i render…all is good…i hit render forward…and it is not tracking.

i am not going to meet my deadline on this project…

Hi there,

Can you send me a screenshot (or better yet, the project) to mary p at borisfx dot com? I am sure it’s just the layer shapes not being set up correctly or the track not being correct in the first place. Happy to help you figure it out.

Hi Mary,
I am having what seems to be the identical problem with the steps listed by Lizbeth. I have always used the standalone app for these clean plate removals with no problem; however, this is my first time using the AE plugin. The BG and cut out shape tracking is fine, but when I render, it appears my remove shape moves cutting a hole to reveal my static clean plate. I am using he latest version of Mocha Adobe plugin and Adobe CC 2018.

Just a few more notes, in case if it helps:
-The first remove render frame / clean plate frame is fine
-Even with all the failed frames rendered in Mocha, I go back to AE, click the render check box, and select “remove” from the drop down, none of the renders follow.
-I’ve also tried having the BG layer and remove shape layer reference their own tracking data AND I had my shape layer linked to the BG layer tracking data. Same failed results for both options.

Hi Stephen,

Can you send me your shot? Mary P at Boris FX dot Com? I never heard back from Elizabeth Harrison, so I was unable to troubleshoot her shot.


Thank you for the quick reply. Everything is working as it’s supposed to. Clean plate is tracking and the render option is working in the plugin. I wish I can say what the solution was. I created a new project, new clean plates, and refreshed all my caches and preferences in every app in the chain. Thanks again.

It was probably resetting the caches that did it! Sometimes a bad cache can cause hiccups in the render.

Can you tell me how to reset the cache in Mocha Pro?

Go to File > Clear Cache and select all the options, then OK.
Note that “Global” clears ALL mocha project caches, not just the current project.

1 Like

Hi there,

Please note that I thought - yesterday again in my last project - that Mocha could/should have its cache controls highly improved… When you know the piece of software by heart, it may be ok, but caches sometimes seem not to be updated, and other stuff are weird too.

For example, not a cache matter for sure, but make an insert or remove, render a few frames ahead, come back to the first rendered frame, read backwards : no image.
To recover it, you have to go to Clip > reselect the input clip again (even if it was on yet, just re-select again on the drop down menu) > go back to the insert or remove tab : you’ll be able to read again the frames that were not rendered…

Essentially what you’re requesting there is a “show original” when there isn’t a rendered frame, correct?

Also just select the “Selected Layer” frame to revert back to the original. You don’t need to select the clip.

Hey, thx for your answer?
Yes, it’s a kind of “show original”… I’m not before Mocha now but what do you mean by “selected layer frame” ? You mean the track itself or a menu elsewhere (sorry if this looks stupid)

This Clip View option here in the View Controls will restore your view back to the original clip you were working with:

Ok ! You actually meant in the top view controls while I was sticking in the tab controls (remove, insert and clip) down below. Sorry to bother you with this stupid question and thanks again martin.

Hi–this is an old post, but I’m having the same problem. Clearing cache hasn’t fixed it. The layer that I’d like to use my clean plate with is working on the first frame that I try it on (which is the last frame of the shot) but then it doesn’t track backwards with the layer. It stays put, and the layer cuts a whole through the video to where the clean plate is stationary.

Figured it out. You have to click edit for the clean plate, then give it the frame number that it was painted on. Mocha is so powerful, but so frustrating sometimes. Wish this stuff was made more obvious.

Glad you’re all set!

Hi, I know this is an old thread, but I’m having the exact same issue. Clearing caches and creating new projects hasn’t worked, and it’s not affected by the frame number in the clean plate edit section.

Any suggestons?

We’ll need to see some more details, such as your remove parameters and the setup of your clean plate list.