Remove Module Blend Dissolve Width not working


#1

Testing out the 5.2.1 Remove Module with a very simple video, a dog wandering around on some sand, and I’m getting some weird results.

Plus the interface is slightly hiccupy.

First the problem. With Illumination:None, Randomize, Dissolve Width: 8 no 3D, No Flood Fill it does indeed produce a speckled 8 pixel boundary around the object being removed.

But as that look pretty bad I selected Blend with the same Dissolve Width: 8. It doesn’t dissolve, it just expands the area that it replaces, with a very visible hard edge between the replacment patch and the area outside it. All values of Dissolve Width from 0 - 100 do exactly the same thing (although 100 grabs some data from nowhere in the video and puts a big splodge in the middle).

Different value of Dissolve Width in Randomise mode do produce larger speckled bands around the replacement area, so it knows where it should be doing the blending, it just isn’t doing it. If it did dissolve, or blend between the two varying lighting sections - as the docs say it should - the results would probably be acceptable.

I added 8 to the Edge width of the object to be removed and retracking the background, thinking this would mean it would use the alpha channel of the object’s mask to fix the problem, but that made no difference. It was just like enlarging the Dissolve Width. The area replaced was just larger, but still with clashing lighting and a hard edge. The alpha edge of the Object to be removed had been ignored.

Next option: Linear. That produced a very blurred patch with almost no contrast that looked nothing like anything else on the video. It also has a hard edge (despite using an increased Dissolve Width of 12) between this blurred patch and the surroundings, so looks worse than using None in every way.

Interpolate produced a better matched result in terms of colour and contrast, but it had hard edges around smaller patches inside the removed section, which it had made up from several other sections. This was despite it again having a Dissolve Width of 12.

Changing to Randomise with the Dissolve Width of 12 and Interpolate: the little internal patches then had dithered lines around them, which highlighted the patchwork nature of the section it was using to make the replacement.

So, with Blend not working with any of the Illumination models, it makes all of them either have hard edges in or around them, or the randomised dithering, in or around them.

Interface issues:

Deleting All Keyframes for the various settings using the (x)ALL button after selecting them and reply yes to "Delete all Dissolve Mode Keyframes " etc. does not delete all Dissolve Mode keyframes. Despite a Blue box highlighting the entirety of the Dissolve Mode area, including the Width, DissolveWidth has its own keyframes. Which need to be deleted by highlighting the actual number itself, then (x)ALL to get the “Delete all “DissolveWidth” keyframes” popup. That still doesn’t work, as despite no keyframes showing, ‘ghost’ keyframes still appear in the Dissolve Width box when on certain frames of the video and have to be overwritten manually to the same value as those either side of them.

Also, despite the Blue ‘selection’ Box highlighting the entire Illumination Model area, (x)ALL on that does not ‘Delete all the “IlluminationModel” kayframes’ because the Smoothing level has its own value “InterpolatedSmoothingLevel” which must be deleted by selecting that value directly first.

3D Compensation , Flood Fill do not have a Blue selection box around them, and they must be selected separately with (X)ALL as ‘Delete all “Use3DCompensation” keyframes’ and ’ ‘Delete all “UseFloodFill” keyframes’ individually.

The Flood Fill Smoothing Level value has its own " ‘Delete all “FloodFillSmoothingLevel” keyframes’, although both it and the Illumination Smoothing level values were often greyed out and inaccessible, despite Interpolate or Flood Fill being selected when they should have been active. One way to make them responsive seemed to be to start to remove a frame, then cancel it, when the removed object would reappear and both Smoothing Level values would become accessible again.

If Blend worked as advertised and the keyframes were actually deleted, then I’m sure the results would be better and it would be less frustrating to use.


Trial Version Mocha VR Standalone - remove - trial version fully functional?
#2

Excellent notes. You should be on our beta testing program. :slight_smile:

The hard edge is not necessarily the patching blend, it could be related to artefacts in the actual track itself. A blend will attempt to smooth between the foreground spline edge and the available background, but if the shift extends across the whole remove area. you ill see issues. If you can send an example clip of the project you used, we could see if we can help eliminate these issues.

You can either send an example to me directly (martinb[at]imagineersystems.com) or email support@imagineersystems.com with a link to the problem footage.

In regards to the keyframing, we have added keyframe improvements to the 5.5.1 version of mocha Pro, which is scheduled to be come out this week.


#3

I emailed you a link to the file along with the steps I took, but have no response.

Maybe check your spam folder? :slight_smile:


#4

Thanks, you’re right, it was there!

I’ll review and respond.


#5

Thanks. I got your reply and if you’ve not whitelisted my email address: there will be another response with further examples in your Spam folder. :slight_smile:


#6

Martin, check your Spam folder again for some project files I sent a week ago. :wink:

I got an Out of Office for a non-existent day: Friday 14th March (14th was a Tuesday) :slight_smile:

I looked at v5.5.1, but the ‘fixed issues’ in the docs don’t really mention anything about the keyframe improvement in the Remove module, just the Keyframe buttons updating and allowing you to delete one you just created.

As I said in my post to you with the project files, but for the benefit of anyone else interested: an accurate track is the most important thing to get a good Remove, and that can obscure the Dissolve Width not Blending, because if the background doesn’t have a lot of lighting changes, you won’t notice the contrasts between the segments of the patch it uses to make up the full replacement patch anyway.

However, a pretty sloppy track - as I had the first time - and/or lots of contrast/colour changes between frames - which I also had - makes it more visible. Mocha doing most of the process well is obscuring that last bit of polish where (I think) it’s not actually blending, just replacing.


#7

I am having this exact same issue, randomize looks like a glitter sparkles around the edges of the matte, and blend does nothing, leaving the very noticeable hard edge.


#8

Hey, I must have missed those files. Not sure why our inboxes don’t like it! I’ll review and get back to you.


#9

Glad it’s not just me. :slight_smile:

As everyone else has probably discovered - and hence not spotted the issue before - is the track needs to be very accurate first.
Had my initial track been better I probably would not have spotted the blend issue in the first place.

It almost works as a “Do a better track instead of using this to fix things” indicator. :slight_smile:

Martin kindly sent back a project file with a very accurate track of the dog, and the remove was almost perfect on what was some very poor quality, shaky footage.

It was so good it was almost impossible to tell the blend was not blending. This result is evidently fine for 99.99% of users or they’d have complained before.

So, until there is any sort of a fix, retracking to be more accurate will almost certainly give an acceptable result.


#10

Following up on this, and this is directed at MartinB, what’s the plan to fix this?

As we know from the various tests I sent you, and others reporting similar issues in Pro and VR, the ‘Blend’ part of Dissolve Width is not working correctly in that it’s not a ‘Blend’ at all, it’s just a ‘replace’ of the Width and produces a hard edge around the remove patches if the lighting differences are significant between source and destination frames.

The Randomize option shows up where you’d want Blend to be doing it’s job, but no one wants random, noisy pixels jumping around, so that’s feature that no one would use if Blend worked. You could probably remove that function entirely and no one would complain, TBH.

This must have always been there, but getting a very accurate track and having minimal lighting changes hides that Blend (probably) never worked; but when it’s needed: the fallback of using a cleanplate doesn’t work if there are large perspective or size changes; as the detail blurs in noticeable ways. You then have to use multiple cleanplates, which is just awkward if Blend would have done the job by itself. There are compensations in the speed increase you recently revealed in using multiple cleanplates on shots that it would work with, but that’s not really the point.

tl;dr when is Blend going to be fixed to actually blend and not just replace?


#11

We’re looking into better solutions for this, but at present, the blend is best done with the edge width matte via the plugin.

If you’d like to be on the beta program to check ongoing changes, you can sign up here: https://www.surveymonkey.com/r/ML228BV