Remove module - extra pixels leaking through around tracked mask?

Hey there,

I’ve noticed an issue I’m having with the remove module lately, I must be doing something wrong but I can’t figure out what. Will post my steps below, and then screenshots at the bottom.

WORKFLOW

  • Doing a simple remove on a relatively simply-moving object.
  • Track a large swathe of the area I want to cover (ensuring my remove track can generously fit within it). Make sure the track is solid.
  • I draw a mask around the part of the image I want to remove then link it to my larger-mask track. They move together just fine.
  • I select inner/outer mask edges of my removal mask and feather a bit (thought this would help with my leaking pixels issue but it isn’t)
  • I go to the remove module and identify my clean plate. It always defaults to “all” for the frames (I still don’t understand why) so I manually enter the frame which applies for my cleanplate.
  • Set illumination to linear (found that works best, don’t really understand why)
  • I hit the gear to render for my clean plate frame and it works perfectly.
  • HOWEVER, any further frames have a strange pixel leak around the edges of my remove mask (see images). Not sure why.

Any help would be appreciated. Thanks!

Original image:

My track:

First frame of removal (looks perfect, overlays off):

Second frame of removal (with pixel leak?, overlays off):

EDIT
I ended up getting the shot I need by just doing it manually - applied full-frame-expanded transform to my cleanplate in AE then set it to mask itself + feather and it looks good. Just needed to do some keyframe Lumetri animation to get colour to match properly as it shifts slightly. But would be nice to be able to do this with the remove module, and to take advantage of its frame/colour blending so the colour looks nice and natural without me having to keyframe in AE. LMK! Thanks!

Hello!

I’m not quite seeing that pixel leak you asking about. Can you check Is that the right screenshot attached?

Hi there, thanks for the reply!

Here’s a zoomed in screen grab - basically there are some extra pixels “leaking” (?) around the edges of my remove mask:
image

With mask on:

Thoughts?

Hello!
Apologize for the late reply. You’re using clean plate that was painted somewhere else, like photoshop, right? I don’t see you mentioning it in your workflow steps.

Try turning on “Use Cleanplate Exclusively” checkbox.
Does it helps?

Hi there, thanks for the reply!

And that’s fantastic, “Use Cleanplates Exclusively” fixed it - thanks so much!

If you don’t mind, can you please give me a bit of explanation or context on why that fixed it? I’ve been using Mocha Pro for simple removals for years now and I still have no idea what “Use… Exclusively” actually does?

Also, yes, I made the cleanplate in Photoshop. Not sure what the context of that statement means though - don’t you HAVE to make the cleanplate in Photoshop (or another image editor)? Is it possible to paint/make a cleanplate some other way, and is that more effective, or same difference?

Thanks!

Glad that helped!

The thing is - there a 2 ways of how the remove module works.

The one is, when you make you clean plate in external software, like Photoshop, and then import it into Mocha. That’s when you want to use that “Use clean Plate exclusively” tickbox, cause it’s literally what it means.

The other method, is when Mocha removes objects automatically. It analyses all the frames, and looks for part’s of the image that can be used for a clean plate, and build that for you. But for that method to work, you would need to have frames where the unwanted object is not in the frame, or it changes position. So this method won’t really work for your phone’s black bar remove. But here’s a great tut that shows exactly how it works