Remove module in locked-off shot (for lighting compensation)

I’m trying to use the remove module in a locked-off (tripod) shot right now. It doesn’t move at all, but the camera’s exposure changes quite a bit, and it was proving to be a bit too much to match that by hand.

There’s a clean plate right at the end of the shot that gives me 100% of what I need in terms of a clean plate. The problem is, the remove module seems to completely ignore my background layer, possibly because I haven’t tracked it. Again, there’s no reason to track, it’s locked-off, there’s absolutely zero motion involved. I suspect this is the case because when I couldn’t get it to remove, I tried letting the background track for a little while, and suddenly the remove module wanted to work. Of course the results were unacceptable because the track was off, but it shows the lighting compensation working perfectly.

Is there a way to force mocha to use the background layer, even though it’s not tracked, or lacking that, is there a way to trick mocha into thinking it has been tracked?

Unfortunately, you will have to track the BG. But it should be a simple track, just pick a feature that doesn’t move or get obscured and track translation only. Use that as your BG Layer.

Please let me know if you have any questions and I will be happy to help you.

 

Cheers,
Mary

I tried doing this, and unfortunately it’s a long shot (about 1100 frames), and even picking an area where there’s no motion, mocha slips off a tiny bit over time, leading to a completely unacceptable result.

I managed to get it to work on the left eye, but doing the right eye now, I can’t seem to trick it into doing what I want. Can you or one of the engineers shed some light on exactly what mocha is looking for in an acceptable background layer? Yea tracking it would do the trick, if only tracking it didn’t cause it to slip off too easily, but the fact that I got it to work before just by copy+pasting keyframes proves there’s something else going on under the hood.

 

Hi Trevor,

You can always use manual track. Please do the following:

Scrub to the first frame of your shot.

Go to the tracking tab.

Click manual track.

Click the Align Surface Tool

Click +Add keyframe on the timeline.

Scrub to the last frame of the shot.

Click +Add Keyframe on the timeline.

You will now have a perfectly solid BG track locked off. Try that, I just tested this on a shot and it worked perfectly. Let me know how it works for you?

You will probably have to use cleanplates exclusively.

Cheers,
Mary

Hmm, it still isn’t working. It’s a bit slower than it was when I’ve had the settings wrong (eg it’d flip through the frames really fast – too fast to be doing anything useful), so it’s definitely thinking about something, but the output is the same as the input.

Quick checklist for what I’ve done:

  • “foreground layer”, has a matte clip applied to it, it’s the very first layer.

  • “background layer”, the “locked off” layer. Followed your steps to the letter.

  • “Illumination Model” is set to linear.

  • “Use Cleanplates exclusively” is enabled.

  • Using mocha pro 4.1.2 (most current version, to my knowledge)

  • blend modes for both layers set to “add”

  • foreground layer tracking settings all at defaults, haven’t been touched – I used a matte clip instead.

  • I re-made project from scratch inside of mocha just to be sure, still doesn’t work.

  • foreground layer selected when using remove module.

  • clean plate grabbed from frame that is NOT the last frame of sequence – there’s a slight bump before the end frame, so I’m grabbing one 22 frames earlier. The bump doesn’t affect the shot, the subject has already left frame.

EDIT: here’s where I was inches away from pressing ENTER to send… but I tried one more thing instead.

I went ahead and tracked that teensy tiny bump at the end of the shot with it set to “small motion”, just to give the tracker SOMETHING to chew on. All of a sudden, the remove module started working again.

Thanks for all your help MaryP! I hope this issue can be addressed in a future build of mocha. That illumination matching tool is good enough to work on its own, and it should be allowed to, in my opinion. Cheers!

Happy to help, and we are always looking for ways to update and improve the product. I will let our dev team know about your suggestions.

Cheers,
Mary