Remove Module Problem

I’m using the remove module to reduce the eye bags under an actors eyes… and it’s mostly working great!

I usually use a couple of cleanplates, and either “linear” or “interpolate” in the remove module.

However, during the render process, the shape that is being “removed” will occasionally be rendered solid white, or sometimes a green or blue. So Mocha might render the first 10 frames OK, and then suddenly throw in 1 solid white shape, (not the whole frame - just the tracked shape) and then go back to rendering OK. This might happen on three or frames in a 40 frame sequence.

I can go back to the errant frame after the render has finished, “undo render in current frame” and then hit the “render frame” button which will normally correct the frame.

I then have to “export rendered clip” to avoid still having the “bad shape data” in the rendered frames.

Any ideas on why this is happening.

Thanks,

Hi there,

What images are you using as the input file inside of mocha? Some image formats don’t seem to always render properly, and we’d like to make sure it’s not a bug.

Can you turn the surface and grid tool on under the eye and tell me if they’re “sticking” to the under eyes properly? If the surface disappears then there may be bad tracking data causing the issue.

Do you have offscreen buffers disabled in the open GL tab inside of mocha’s preferences? Keep them off if you have rendering issues.

These are three things that could be causing these problems. Please let me know and I can guide you further.

Cheers,
Mary

Thanks for the response…

Your second point might be my problem. When tracking images into monitors etc I always pay close attention to the surface and grid… however when doing these cosmetic fixes I had not been looking at that data - and indeed I did lose the surface and grid half way through the track.

I have been tracking the actors cheek/lower eye with one shape, and then putting a second shape that defines the eyebag completely inside the first shape and linking its track to the cheek shape and using that shape in the remove module. The cheek shape usually tracks the motion of the face very well, and hence the eyebag shape inheriting that track looks great on screen. Obviously not well enough to not lose the grid though. Do you have any tips for this kind of work so as not to lose the track - especially for the case where an actor turns their head from facing forward to looking to the side - an extreme perspective shift?

As I indicated earlier, the curious thing is that using the method above I usually only get a few “bad” frames (i.e. the remove shape rendering solid white) per short sequence of frames (usually 50 - 300 frames) - and they can be corrected on a one by one basis. (Although this is obviously tedious and frustrating)

To answer the other questions - I am using sequential 16bit .DPX files (both for input and output)

The offscreen buffers are not disabled - I will try that next time I am running out a sequence.

Thanks for your help with this problem - I am a big fan of your tutorials!

Cheers,

Simon

 

OK, it’s probably the extreme perspective shift problem from your description. To get around this, use manual track to jump ahead of the areas where the face turns and there is not enough data to track and track backwards to the turn from where the face is the most parallel to the camera, OR track the areas between the turns as separate remove areas. When you lose the surface tool like that, there is no more data for mocha to use to generate the remove.