Removing reflected shapes on screen

Hello!

I’m giving my first steps in the remove module.
I shot the following clip of a blood pressure monitor, without green screen, nor the possibility to cover the ceiling.

I rotoscoped the device, applied the matte and stabilized it.

Now, I’m having difficulties in removing the irregularities of the ceiling that are reflected in the screen. I created a clean plate and cleaned the screen. I tried with following parameters.

Below is the result.

The patch is not aligned and the transition is noticeable.
I’m not sure if the clean plate is useful at all, since the light changes throughout the shot.
Does anyone have an ideia how to improve this?

Thank you in advance.

OK, so first of all, I suspect your track isn’t rock solid. This is complicated by the fact that the screen is ever so slightly curved, so that’s going to be a pain right there. However, I think with an improved track, a feathered shape, and using illumination modeling you might get better results. And make sure you make two cleanplates, one at the end and one at the beginning. That will also help to counteract the curve issue.

Step one: track the edges of your device but grab text where it is available inside your tracking shape to help in the track. Next, use adjust track to make sure the BG track is rock solid. Link a new shape covering the entire device to this track when the track is complete and make that your remove BG.

Step two: feather your ceiling anomaly shape by adding edge width to your remove shape.

Step three: make a cleanplate on the beginning and end frames. Check the “use cleanplates exclusively” checkbox.

Step four: use illumination modeling in the remove, try “linear” and if that doesn’t work, try “interpolate” to handle the reflection changes.

Try that and let me know. If that doesn’t work, try patching the screen with the insert module and curving the patch with the grid warper inside the insert module, then hand color correct as the lighting changes and composite with a feathered shape back over the top of your original shot.

Please let me know if you have any questions and I will be happy to help you.

Cheers,
Mary

1 Like

Well…
First, the clip is longer with more anomalies to remove.

Now, let’s see if I understood correctly.

Step 1: I decided to track outer white frame edges to use, since I need to remove anomalies there as well.

The problem is that I never used the Adjust Track before, so I have no idea how it works. :confused:

Step 2: I have 4 ceiling anomalies, throughout the clip. I tracked them and feather them as you recommended.:white_check_mark:




Step 3: Here, I have a few doubts. Since I have 4 anomalies, should I make 8 clean plates at the respective beginning and end frames, or just 2 at the beginning and end of the clip? After retouching them how do I use them in the removal. :thinking:

Step 4: I haven’t reach this one, yet :roll_eyes:

Could you, please, guide me trough?

Thank you.

For step one, I can’t tell what your track is doing without seeing the surface tool. The shape is only where the track is looking, the surface tool is what the track is doing. Probably it is drifting, I see you had to adjust your shape keyframes.

Adjust track tutorials can he found here: https://borisfx.com/videos/quick-tip-adjust-track/

You don’t need a bunch of cleanplates for every anomaly, just the two unless you get an error that makes it look like you can use more, then I would pick a new cleanplate from the middle of the shot. And all the remove shapes can be on one layer. Just animate the shapes over your anomalies and you’re good to go.

1 Like

Here is the device track with the surface on.
I didn’t do any adjustment.

I put all the remove shapes in one layer and animated them.
I retouched the clean plates.
I started to render the remove.

The good news is the removal itself is very good.
I just need to refine the shapes.

However, Mocha only performs the removal in one of the shapes, on the bottom left corner. It doesn’t seem to act in the others.

How can I put it to remove in every shape?

Thank you.

Delete your renders and your cache just to be sure in Mocha. Then, make sure the BG shape covers the entire screen of the device where your shapes need to be removed, looks like your removes are all on one layer so it should do all of them. Your track looks rock solid now.

Try that and let me know.

Very well.
I did what you told me and still, the render only removed the reflections in the same shape.

I took a look at my layers and the upper one “BGD” was not in use.
However, since it was above the layer of the removals, I thought it didn’t interfere, so I let it sit there.

3Layers

This time, I deleted it, just to be safe.

2Layers

I tested the render again in one single frame and it did perform the removal in every shape.
I did the first run with “linear” illumination. The result was better, but I noticed a lot of light changes, so I changed to “interpolate”, which had smoother transitions but the light difference was very noticeable and it created some glare in the edges.
So I created another clean plate in the middle and tried again in both modes. The result was better, but still noticeable. I created two additional clean plates in the quarters, which happened to be where the light differences were more contrasty.

I did a third run, with the results below.

Linear illumination

Interpolate illumination

In linear mode, the transitions are not so natural.
In interpolated mode, the the transitions are smoother, but there’s still a bit of glare.
I don’t know if I could improve the removal by adjusting the settings of the illumination modeling, with more clean plates, or with something else.

Overall, the results seem good, but I’d like to have your feedback.

Thank you for your patience.

This looks much better!

Sorry I didn’t notice your top layer, that definitely would have caused that not to render.

I think this result looks good.

Cheers,
Mary

Thank you everything, Mary.

Kindest regards,

Miguel