Removing the Edge of an Insert Clip

Hey all

I’m trying to clean up a clip by inserting .png images–that I edited in Photoshop–into various layers, but when I render them out and export the full clip, there are these tiny little outlines on the inserted images that I just can’t get rid of. I’ve tried the ‘Antialiasing’ and ‘Enhance Edges’ parameters in the Insert tab, as well as the Edge tab ‘Lock’ options, but those just make them worse.

I’m getting really frustrated, and I just can’t get past this.

Any ideas??

How are you saving out the PNG files in photoshop? Can you post an example file?

When I import this png as an insert I do not see any edge issues in 3.2.0.

Are you working in any particular colour space? What is the format of the footage you are using (ie. the tracked footage, not the insert)?

Let’s check a few things:

  • Do you have QuickTime installed? This should not matter, but it’s worth checking.
  • Are your graphics drivers up to date?
  • If you insert one of the default clips, such as the “mocha” logo or one of the grids, do the edges look strange on those?

Okay, good that it is working, but odd that it was wrong before!

Let us know if you get the same issue again with a different project.

It may be the alpha of the original image has some errors, you can try to erode the PNGs in another program and resave them.

Or you can use roto shapes to cut them out in the insert tab.

Thanks for the suggestions, Mary, but unfortunately, they’re not working. I’ve done everything I can to erode the alpha channels in Photoshop (I guess PS is really finicky with transparency and premultiplied alpha channels). I never knew how to use roto shapes until I saw your tutorial (featured here: Exporting Color Roto Shapes using Mocha AE and Mocha Pro 3.1 - Lesterbanks), so I tried both an alpha and a color-shape export to put in another layer, per a tutorial I found here:

Didn’t work. I’m still getting the little outlines on all my inserts. Doesn’t matter so much for the border inserts: they’re solid black, so the Erode Alpha option under the Comp tab in the Insert module works just fine for that. I’ve linked a screenshot of what I’m looking at, so any further help would be fantastic.

Thanks very much

I didn’t know there were other ways of saving it out. I’m doing File>Save As>.PNG. I’ve tried every setting I can think of, and every filetype with transparency (.tif, .tga, .gif), but nothing works.

Really? That’s strange. I do have the Erode Alpha parameter set to 1.21, but that’s because the edge looks awful without it, like this:

All of my other settings are at their default values, and the clip is a sequence of .tif files: HD, 24 FPS, RGB, linear colorspace, gamma 1, no interlacing.

QuickTime yes. Drivers yes. Default insert clips, no. So I suspect there’s something wrong with my custom insert clip, because when I don’t have “Use Insert Clip Alpha” selected, the Planar Surface is white around the image.

I have the same problem! No way to get rid of the white edge.
I’ve tried everything including a masked still frame directly in AE. Please is there someone that have been
able to fix it?

This actually sounds like a Photoshop thing that used to drive me absolutely crazy when I was creating Matte Paintings with clouds. It likely has to do with how the image is being saved out: Use transparency and mattes in Photoshop Elements

You can also try a TIFF with an alpha instead and make sure you don’t have black or white in the actual edges of the object. Sometimes PNGs and other “transparent” images save the background color as part of their transparency.

If you’re still having issues, send me a screenshot?


Just a word that may help, because this drove me crazy too a few months ago… Actually, I fixed it - after a long testing time - by making a matte file way larger* than necessary and applying a very progressive transparency on its edges.
*this means instead of letting say 10 px all around the file, I let 60 px and apply a very progressive alpha from outer edge 0% to inside edge 100% (where the alpha starts to diminish). It worked great without tweaking anything about the file format…

Hi Mary!!!
Thank you for getting back to me on this!!! I think I’m doing something wrong because I’ve also tried to use a masked solid in AE to see if it was a photoshop problem but the white edge are there as well!!!
Inside Mocha it looks fine it’s when I come back to AE or premiere that I get the white contour.
Please let me know as soon as you can!!!
T H A N K Y O U ! ! ! ! ! ! ! !


@ Mary and Factorysam: thank you for your advice!!! I was trying another way.
What worked for me was to export the mask, so I nested the cleaned clip with the white contour on the top of the original clip and used the mask with reduced contours to erode the white borders. I think there is somethign wrong here that need to be fixed. I’ve spent an entire day to get this clip fixed. I wish you both a very nice day!!! Davide

Did you try a TIFF?

And yeah, if you’re using a matted solid and it’s doing this that’s very odd. I will run some tests.


Has it been fixed? I know this is a really old thread.

I am having the same black edges problem. The logo insert is a AE comp with a solid layer with masks.

if I render Insert: composite, it looks fine, but the edges shows when I render Insert: Cutout.


The same happened to me and I had to use some complicated tricks out of Mocha to make it works. If I don’t mind I made the tracking zone bigger then I needed and then I cropped the area in AE…

Perfect I’ve just seen I had already answered to this topic an year ago!!! Shame on me!!! :slight_smile:

You can also change how inserts render in your preferences now, and choose what algorithm to use based on your needs.