Render blue bar & stop render button not working?

Hi, if a click the render arrows backwards or forwards the stop button that appears in the middle between the arrows doesn’t work, i have to press ESC to stop it rendering, Standalone & plugin,
also if i choose Undo render in all frames in the Edit tab, why does the blue line remain on the timeline, even after i’ve cleared all cache & deleted the spline?
Thanks.


Hmm. That seems like a caching error. Let’s let @martinb know.

1 Like

& i don’t remember it being like this but if i put your logo in the insert


& then press render, the logo gets blurred/pixelated?
then Undo render in all frames i can’t replace that insert with something else until i click render again, then the new insert appears, but that too looks blurred,

I just tried it on the video with the Mocha Plugin

Video & sample text added

Sign with spline & text as insert layer

press render & the text goes blurry, nothing in any of the tabs at the bottom has been changed.

What rendering setting are you using in the Mocha project settings? You can change it for different results.

Sorry where do i find those settings?

The dropdown called “resampling.”

Ok thanks, tried all 5 options, insert still looked the same as above.

If you apply it as a corner pin, is it any crispier?

Hi @Gid.Joiner

In terms of the render button not appearing:

  • What version of 2022 are you running? v9.0.2 or v9.0.3?
  • What is the size and format of the source footage when you get the render button error?

The blue line is representative of the number of frames rendered. This exists even if you delete the clip to mark where the render got up to last time. It really is a cosmetic thing that should be cleared up.

The insert blurriness is simply a result of converting a large insert image to the current resolution set by the source clip and the scaling of the surface. It’s not really blurring so much as it’s adapting to match the correct pixel resolution and scale. If you look at the pixelated parking sign behind the text you’ll see that the pixelation and blurriness are matching.

For example, if you try expanding the surface to the full size of the screen, you won’t see the same level of pixelation or blurriness.

Plugin
plug
standalone is the same i guess,
stand

If you look at the pixelated parking sign behind the text you’ll see that the pixelation and blurriness are matching.
OK, i did consider that, i guess it’s just because the writing is bigger so the pixelation is more visible, :+1: both the text & video media is 1920x1080 so it was nagging me a little because when at first adding the inserted image the quality is crystal clear but then when render was clicked it goes blurry, zoom back out tho & it’s a bit more in fitting :exploding_head:

It’s the square Stop button that replaces the round cog (Render Current Frame) that does appear when you render forwards or backwards, but when i click it to stop rendering it doesn’t work, i have to quickly click twice (normally more than twice) to stop render or use ESC,
Thanks.

& the blue bar / Uno Render In … not wiping the slate clean means that if i put an insert in the blue Planer Surface box, then press render, i can’t then change it & put something else in instead, like your logo or chequer board without having to click the render cog to make the new insert show, but then adjust the opacity, gain or blend mode & the insert immediately disappears, clicking the render cog makes it show again but this is a pain when trying to fine adjust, every adjustment means the cog render button has to be clicked,

Ah, right! This might be because the process is rendering quickly enough that we’re not catching the mouse event between frames. I’ll see if we can speed up the interaction event to catch it earlier.

1 Like

There’s two options here:

  1. Turn on “Re-Render on parameter change” to keep the rendered frame updated on any changes. This doesn’t work for all parameter changes, however.
  2. We add an option to switch back to preview mode when you adjust something. Right now if you want to preview new changes after render you need to select the “Selected Layer” clip in the viewer.

1 Like

:+1::+1: I have quite a fast PC, the cursor does wizz along the timeline so i understand, the catching the mouse event between frames :+1:

I turned on the Re-Render on parameter change & after rendering the insert I thought, 'that doesn’t do anything, it still disappears when i change the settings in the insert & still have to keep pressing render to update/show the inserted image :unamused: but…
choosing Selected Layer fixed everything, i can now adjust opacity/gain, change the inset, change blend mode… all updating in real time
Thankyou, sorted :grin::+1: