Rendering in Premiere Pro


I watched Mary’s tutorial here: Mocha Pro Track & Replace Logos on Curved Surfaces - YouTube

I am trying to add text to a tracked clip. It looks fine in Mocha. However when I exit back into PP, the rendered composite does not appear/ Under Module I have "Insert: Composite, with inster layer Video 1 and the Render button checked. I hav tried clearing cache but still does not appear.

Additionally I tried to export the rendered clip from Mocha but it appears it’s rendering just the matte.

Thanks for your help.


What version of Mocha are you using?
What version of Premiere?

And what does your shot in Mocha look like when you say it is rendering just a matte? How is your shot set up? If your render is not appearing properly in the Mocha Pro plugin and is appearing just as a matte, then it certainly will not appear properly even with your render setup working correctly in the plugin interface in Premiere.

I need to know more information to help. :slight_smile:

Hey Mary

Thanks for the quick reply.

I have sorted it now.

FYI it was rendering fine in mocha plug-in but not appearing when reverting back to premiere and clicking render in the effects panel.

The problem was that the tracked source file needed to be right clicked within premiere and scaled to frame size. (1920x1080). The insert layer was the correct frame size but because the source file was not it did not appear. After I changed it in Premiere the render appeared.

Thank you, that is very useful to know for future troubleshooting.

Thanks! I had the exact same problem and it was driving me crazy. One thing that was interesting was in Mocha Pro if I imported the clip for the composite, it would be the correct size, if I used the insert layer it was not, so that should have been a clue for me. After fixing the size the insert layer was the correct size in Mocha Pro and then everything rendered correctly in Premiere.