Resetting the Planar Surface for a track region?

Working on an Equirectangular project in flat view and I dragged the Planar Surface corner points for a tracked region somehow and the actual blue planar region has disappeared. Toggling it on/off via the UI widget does not reveal it any where in the frame. Is there a way to reset the planar surface widget for a given track?

Also not able to get the pink grid to display…

The track took about an hour, so starting from scratch with a clean spline would be a bummer.

It is possible that the surface has literally gone behind the camera - which is difficult to explain but will indicate a problematic track in a normal non-360 project.

To restore the surface, you can select the “expand planar surface” button to the right of grid:


1 Like

Wow - this is crazy. It almost appears as though the Planar Surface outline is inverted. I followed your input and expanded the surface to the full frame, but trying to drag it back in range has the widget displaying what looks like polygonal facets. I can’t get it anywhere close to my track, and with any corner drags it simply disappears again.

Update: Yep - it was inverted in the frame. Finally was able to get it to flip over on itself by scaling it inside out.

1 Like

It might be nice if we add a “reset surface” option anyway down the line. It seems it would be useful! :slight_smile:


Can you tell me how you flipped it over itself by “scaling it inside out” I am having the same issue and it driving me bananas!! Can’t seem to flip it no matter what I do

If you right click the surface in the latest version of Mocha you can reset it.