Resolution Limit in Nuke?

Working on a desqueezed anamorphic shot (5888x2160) in Nuke. Tried to track in Mocha, when using the OFX node Mocha launches but the footage only comes in blank. When I open the same clip in Mocha standalone it opens fine. Is that an OFX limitation or a bug?

it’s a weird quirk in Nuke that if you’re not viewing the content of the source in the Viewer, the OFX plugin can’t get all the frames.

Hi @rosss,

Yes, familiar with that quirk. But this is a separate problem.

I have my viewer connected with the MochaPro node, and I do actually see the full frame range in the MochaUI, except every frame is black.

Jan

Hi, can you show the controls at the top of the Mocha window? better still a full screen capture.

Sure, here’s the full screen:

Here’s the Nuke script:

image

That works for me all the time in other scripts. Only difference here is the size of the clip. Opening Mocha Pro standalone and loading that exact same file opens without problem.

Thanks, sorry i should have said i don’t have Nuke, tried it out but it wasn’t for me.,
why does the timeline start at 1001?

That’s a long-standing tradition in many VFX workflows.

1 Like

Thanks , I guess that gives space pre & post media shot to work in if wanted.

The plugin should not have an issue with this resolution. Is this EXR or DPX files? Would it be possible share 1 frame so we can test?

@rosss Those are EXR files, rendered from Resolve.

Can I DM you a link the a sample frame?

Jan

What version of Mocha are you running here?

This could just be the alpha issue where Nuke is forcing an alpha of 0 on RGB image. If your sequence is RGB-only (i.e. not RGBA), try turning on “Auto alpha” in your read node.

You can also check this by turning off alpha in Mocha (via the ‘A’ button).

As an alternative suggestion, if you don’t want having Alpha on your source straight in the read node, you can just create Shuffle node right before the Mocha, and hit this to fill Alpha with white.

3 Likes

Thanks @martinb and @elizabeth.postol!

That was indeed the problem. I guess many of my recent projects all were .mov and not .exr and so I didn’t catch this. Adding to my checklist.

2 Likes

We always here to help!

Just so you’re aware, we found a workaround to this problem in Mocha Pro 2022 v9.0.3.
If you’re experiencing this issue in any version past this number, let us know as it shouldn’t still be a problem.

1 Like