Rotoscope suddenly ruined

Hi! I’m having a problem every time I try to rotoscope in Mocha Pro.

I set all the keyframes I need for a shot, it appears to be everything fine and suddenly I find that most or all of those frames are not in place. Still remain the shape and the keyframe, but they’ve moved.
Then I correct all of them, and after some time they’re out of place again.

I tried converting mp4 to exr. sequences, also different ways of tracking (doing the track in a different layer to link then the layer with the matte, just tracking the roto layer frame by frame when needed, only tracking translation to avoid shape changes…) Every time same problem.

Any idea why this happens?

Are use using Standalone, or plugin inside a host?

I’m using a Standalone. I’m a Nuke non-commercial user so I can’t use the plug-in.

Please go to Mocha Preferences, and try switching the “Read/Write” setting from GStreamer to QuickTime, then restart Mocha.
Some specific file formats could be read wrong by GStreamer. We’re aware of this issue, and will try to have a fix in future releases.

However, this shouldn’t really be happening for exr. sequences. Did you mean, that you’ve started a project with .mp4 file, then halfway through transcoded it into sequence, and replaced the source? Or did you create a project using a sequences from the start?

No, I didn’t replace the source. Just started from scratch with different file formats (mp4, .exr, .tiff, and .png) just in case the problem was with a specific format.

Oh ok, I’ll change that setting and try again.

Thank you for replying! :slight_smile:

I’m afraid I can’t change from GStreamer to QuickTime, the following appears when I restart Mocha:

mocha error

Do you have QuickTime installed? Can you share what OS you’re running?

could it be that making edits with the Uberkey active are causing this?

Well, if you don’t use the Uberkey in a right way - totally!
Having Uberkey active makes changes to ALL of the shape keyframes through the whole range.

Sorry I didn’t have QuickTime installed, didn’t know that I should. Now it seems to work fine. I repeated the roto and no problem so far. Thanks a lot for helping!

No, I didn’t have the Uberkey active but thanks for the suggestion. It looks like it’s been solved by switching GStreamer to QuickTime as Elizabeth said.

1 Like