Roundtrip After Effects to Silhouette color match problem

I’m having a problem where I tested rendering a single frame that had been roto’d in Silhouette, I rendered this frame as both and OpenEXR and a Tiff both with RGB and Alpha (was not sure which file format I would need/prefer to use). When I compare these rendered frames to the original Tiff frame I exported from After Effects, the Silhouette Renders as Tiff and OpenEXR are waaay brighter. The only time I get a perfect Silhouette Render to match is by choosing JPG for the output, but If I want Alpha, jpg only creates a separate jpg for the alpha, not like the embedded alpha like Tiff or OpenEXR.

For reference:
The original video files are Panasonic VLOG 10bit, the AE and Silhouette projects are both set to 16bit. The tiff sequence I exported from AE to use in Silhouette definitely matches perfectly with the original movie files being used in AE, but I have only done roto work and no color/brightness tweaks in Silhouette, so I’m at a blank for the reason I’m not getting a perfect Silhouette Render match when Rendering as tiff or OpenEXR. I’m thinking maybe it’s colorspace related possibly? But I have no idea how to correct this for Rendering as Tiff or OpenEXR.

Thanks for any help!!! :slight_smile:

Hey, sorry if this is a late reply to your issue. It sounds like your getting a doubling up of the gamma when you re import your footage back into Ae. First thing you can do to to check this is to do the following in Ae:
open the “Interpret Footage” panel for the file you rendered from Silhouette change the "Color Management " setting to use “Embedded Profile” by checking the "Preserve RGB (Disable color management conversion for this item). This will stop Ae adding a gamma profile which will cause the image to appear brighter.
Let me know how you go, if this does not help we can look for other issues that might be causing it.

Hi, doing what you said works in AE, thank you for that!!
The Silhouette Render now matches color perfectly with the original video when viewed in AE. Just wondering though, when looking at the Silhouette Render in Mac Preview, or just looking at the tumbnails in the Mac Browser, the Silhouette Render looks blown out compared to the AE exported still and video file frame. Is there a way to tweak the Render file on the Silhouette end so that the Silhouette Render will match when viewing in Mac Preview or an other previewers that do not have a ‘preserve RGB’ function?

Thanks again.

So first up what file type are you using. If your using .exr that won’t be possible as far as I know, and you will need to render to something else.
What is your color management setup in Ae at the moment. When you render from Ae what is your settings.
Your standard views are doing what your experiencing in Ae they add gamma. If you have the S_OCIO plugin installed or if there is another alternative for Silhouette you could use that to remove the Srgb curve and render previews that way, but I have not tried that, and that is also destructive and not recommend unless just for preview purposes.

I’ll have to look into the S_OCIO you mentioned, but touching on what you said regarding OpenEXR, I just replaced my Tiff sequence in Silhouette with an OpenEXR sequence created in AE of the same movie file, but I’ve just notice that Sllhouette is not recognizing any of the Roto shapes/cutouts, everything is just blue when I view the Output, but it looks fine with blue and cutouts on the Tiff version in Silhouette. Does Silhouette not do roto/cutouts on OpenEXR files? Is that the problem you were referring to regarding OpenEXR?

Thanks!

Yes Silhouette does work with .exr files perfectly. But I have noticed this and not sure as to why it happens with .exr files

You can try this and should get you going again:

  1. Add a Color to Alpha node after the Roto node

2.Pipe the output of the Roto node into the input and the output of the Roto channels into the Obey Matte input and check Obey you might need to also check the invert option also.
You should be able to view your Alpha channel by choosing the alpha in the viewer.

  1. Add a Premultiply node after the color to alpha node before plugging into the Output node and make sure you check Alpha in the channels to render.

Let me know if this works or not for you.

Ok the fix is simple and only need to change two setting on the imported .exr .
In the node for the footage go to the Alpha settings and set the alpha Type = “Straight - Unmatted” and the Fill = “Transperent” . You most likely had “Fill” set to none.
Let me know if this fixes your issue and gives the same result as you had for your Tiff files.

1 Like

Yes, for any source file with alpha that you want to add shapes to from scratch, select the Source in the Trees Window and change the Alpha > Type in the Node parameters to None.

2 Likes

Hi hasta, awesome, thanks for that!!! Yes setting Alpha: Straight-Unmatted and Fill: Transparent worked!! My roto masks are the only things that are blue now.

Hi marco, thanks for the reply. Could you please clarify what you mean by “adding shapes from scratch”? Setting Fill: None was the default and apparently not what I was needing. Just wanted to better understand when “None” is used/useful. Thanks again.

Hi persyst, when dealing with .exr files (or other files that carry and alpha) you just need to be aware that you might have an alpha channel that you need to tell the host app that your working with how to handle it. In Ae for example this is handled in most cases without user having to do anything or being aware. Silhouette like other compositors assumptions that you know when to change from the default. If you have a .jpg sequence the fill would always be none as .jpg does not carry an alpha channel. Your .exr had been rendered out of Ae with an alpha, and you were most likely unaware that it was in the file. So in short be aware that files that can carry an alpha might have a alpha embedded that your not aware exists. Check the settings in Ae for when you export .exr files and other files that can be rendered with an alpha to only render RGB that is if you don’t need the alpha, or if you do tell your other host apps what to do with it if your not getting the desired or intended result. Does that help?

1 Like

Thanks for the additional info hasta!

So everything color-wise looks like it matches when overlaying/comparing the OpenEXR Silhouette Render to the original footage in AE, but I have noticed that it appears the OpenEXR is VERY grainy, but it looks fine in Silhouette when viewed at the Output Node. Any thoughts, help, thank you!!!

Make sure the After Effects viewer is set to Full resolution and not a proxy like 2:1, 3:1, etc.
ae-viewer

1 Like

Aah that WORKED!! Set to FULL, now it looks correct, thank you!!

As far as the OpenEXR render settings, what default settings should I be using for Compression and Automatic Data Window for pulling the OpenEXR back into AE? In my case the composite has no alpha so I’ve only checked the RGB box but not Alpha and Depth. Does ‘checking’ Alpha just make the file bigger unnecessarily in this instance?

Thanks!!!

See page 293 of the User Guide for how to use the Automatic Data Window. If you don’t have an alpha channel, you would not use this feature since it looks at the alpha channel and determines the data window from that. Then, it writes only the pixels in the data window to an EXR file.

If your composite has no alpha, do not select alpha as a rendering option.

As far as EXR compression goes, it depends on your needs. There are several options because if one was the “best”, then the others wouldn’t be needed.

The OpenEXR wikipedia entry contains a decent summary of the different compression methods.

1 Like