S_Effect doesn't work at all in Vegas after 2022.5 update

Hi, the title says it all, before the update the parameters didn’t show, now the effect doesn’t work at all!


It seems to work in Vegas Effects but again no parameters showing & it doesn’t transfer back into Vegas Pro,


There’s 8 supported hosts for Sapphire, i would’ve expected Boris themselves to have clicked through each of the fxs/filters on each host to see if they at least worked, Beta testers discover the hidden bugs not the major obvious flaws like this, :unamused:

It’s working fine for me (Vegas Pro, Resolve and AE tester here) and params for s_effect have never shown up in Vegas. It’s a limitation in Vegas itself.

What version of VP 19 are you using?

I’ll have to modify what I said a bit.

I just repro’d your case and UG applied through s_effect isn’t working right on my machine either. It’s kind of the inverse of a bug I reported where it mostly doesn’t work but some frames it does, at least on my machine.

UG applied by itself works fine.

I do see some cuda runtime errors that I’ll report to Boris

One more update. I rebooted my machine because the cuda errors were in a plugin that I’d disabled and not in UG or s_effect which usually means the GPU was left in a bad state.

s_effect with UG is working fine now. So this could be a boris issue, a driver issue, a vp issue or a combination of all or any of them.

I’ll make sure to write this up for boris but it would be good if you could post your system specs, and software/driver versions so they have info on your system too.

Hi, thanks, this is next day, the PC has been off & has also been restarted,
I just had a go with S-Effect & UG (took me a moment to work out what UG was :thinking::joy:)
I have a preset saved as a Border that i created quite a while ago.


so applied that & it seemed to work, it flickered a bit at first but seemed to correct itself & settle into the correct place after a couple of loop plays,
so i opened Edit Effect, removed the Crop & Vignette, then added UG, back in Vegas it just removes the border leaving like a ghost

Removing S-Effect completely, New project same media, added the default S_Effect - Edit Effect - Added UG

back in Vegas it works but flashes like a slow strobe effect,


:man_shrugging::man_shrugging:
My specs are in my Profile but they are -

Vegas Post 19, HitFilm Pro, Boris Continuum, Sapphire, Silhouette Standalone + Plugin, Mocha Pro Standalone + Plugin, Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD 7000MB/s Read, 5100MB/s Write
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU

S-Transition doesn’t work either :unamused:

@Alan_Lorence
Interesting results with:
s_effect using the 35mm (Academy Ratio) preset
VP 19-636
Sapphire 2022.5

The effect starts off small and in one corner of the preview window and quickly goes full size but flickers over time.

I thought this would be one of those that’s “fixed” by restarting vegas but that’s not the case.

What does fix it is opening the fx editor and closing it. This also has the side effect of setting VP’s ‘dirty’ bit even though I didn’t make or save any changes in the fx editor.

I’m not seeing any errors in the error log

https://drive.google.com/file/d/17Kdc2dQAbYWJZc2QQXdBXcY_Iy319b_e/view?usp=sharing

Just to clarify:

  1. Apply S_Effect
  2. Load a preset – produces strange results in Vegas
  3. Click “Edit Effect” to open Builder and close by clicking OK button

It then works correctly?

Mostly. The final step should be… Close the builder by clicking Cancel

Hi, the best i can get is the S_Effect added effect flashing on & off when Vegas timeline is played, most of the time its nothing, opening the fx editor and closing it makes no difference on my PC/Vegas,

This is a known issue that we’ve been looking into for a while. Can you verify that turning off GPU for Sapphire does NOT fix the problem for you?

I assume that S_Transition is the same?

And just to be clear, Sapphire 2022.0 was working with this exact same version of Vegas?

Hi, There is a slight improvement turning off the GPU but i have an AMD CPU with no on-board graphics,
yes it worked fine up until the most recent Sapphire update,
I know Vegas isn’t the easiest host for you to deal with but thanks for looking into it :+1:

YT vid of how it goes at my end
https://youtu.be/zghsxYi6Jm8

For the problem I wrote up above, turning off GPU use works around the problem temporarily until I restart VP and then the problem reappears. I verified that GPU use was still turned off after the restart.

Interesting wrinkle though. When I bring up VP after having turned off gpu use and saved the project, the fx doesn’t work properly. If I then open the fx panel and click on Help, it shows that GPU use is disabled, but the effect plays correctly from that point on. In much the way it does when opening the builder.

We are working on a fix for this in an upcoming maintenance release.

1 Like

Hi, just thought i’d let you know, Sapphire just updated 15.51,
I’ve only had a very brief trial but S_Effect & S_Transition seem to be working,
Thanks :+1:

Excellent! It took us sometime to figure out what was going wrong with VEGAS and S_Effect, but happy we got it fixed and live.

I wish I could say the same but I’ve updated to 1.15510 / 2022.51 (it’s confusing that different areas of Sapphire show different version #'s) and I’m seeing the same behavior that I last described above.

I’ve also updated to the latest Nvidia studio driver which included fixes for Sapphire.

:unamused: think i spoke too soon, just tried it now, added a simple Crop + edge softness & it’s as it was, flickering on n off :unamused:

Yeah , I reinstalled GPU driver, deleted Vegas AppData, S_Effect is still messed up
I added a preset - Bokeh, that just flashed on n off, went into Edit Effect, removed Bokeh & added UltraGlow @ default settings, it removed the colour fro the media & Bokeh remained

S_Transition seemed to work the other day too but is now flashing :confused: