S_motionblur inside nuke?


#1

Hi ,
I am trying to use sapphire’s s_motionblur node inside of nukeX but I am getting undesired results.

Can anyone post the proper setup to use Sapphire’s Motionblur node inside of Nuke?

For example, when I drop the S_motionblur node onto my fluid render (with alpha channel) my pipeline goes black. (no alpha) I tried using a copy node and using the alpha from my render but Sapphire seems to blur just the RGB and not the alpha.

Very frustrating because when I use Nuke’s motion blur, it works as expected but Sapphire’s node gives better results then Nuke’s. Unfortunately, Sapphire removes my alpha channel and shows up with a black background.

Any help would be appreciated,
Thanks!

EDIT: UPDATE:
Strange, just tried it in Nuke 11 and it works as expected. However, in Nuke 10.5, it doesn’t produce an alpha channel or doesn’t allow the alpha to pass thru the motionblur node. Yet in Nuke 11, it does. (Go figure)


#2

Since it works in 11 and not 10.5, might be a Nuke issue, but we’d still like to take a look. Can you send us a very simple setup that shows the problem?

Alan.


#3

Strange but I just went to make up a sample to upload and it’s working in 10.5. (go figure)
I’m guessing I must have had something in my pipe chain that was causing this to turn black.
(although I copied & pasted the same script in both 10 & 11 and it only worked in 11) So I’m guessing that whatever I had in my pipes in 10, wasn’t a problem in 11. In any case, its working on a fresh project.

So thanks again for the help,

Lou