Sapphire 2022 crashing in RESOLVE 17.4.2

Hi!

Today i installed (updated from 2021 Versions) BCC Continuum 2022, Mocha Pro 2022 (OFX) and Sapphire 2022 on my machine for use within Davinic Resolve 17.4.2.

All works, but Sapphire crashes immediately Resolve as soon as i launch a filter.
Doesn’t matter whether in Timeline-FX, ColorFX or Fusion-Tab.

Sapphire is activated and i also trashed “OFXPlugInCacheV2.xml” in /users/Library/ApplicationSupport/BlackmagicDesign/DaVinci Resolve".

I also did a complete re-install of Sapphire 2022, but that doesn’t help.
Any ideas?
btw. BCC 2022 and Mocha Pro 2020 both work fine…

My Machine is a 28-Core 2019 MacPro with 192 GB, RADEON VEGA II PRO DUO,RADEON XT6900XT and i am on Mac OS 11.4.

THANKS!!

1 Like

Hello, and sorry for the difficulty.

I believe the following will help, but don’t have similar hardware to confirm.

In a terminal window, launch a text editor (enter the admin password when prompted by the system):

sudo nano /Applications/BorisFX/Sapphire\ 2022\ OFX/config/s_config.text

Page down to the end of the // Resolve section and add the following around line 178:

host_gpu_integration:Resolve: 0

Type Ctrl-o and hit enter in nano to save, then Ctrl-x to exit.

Setting that flag to zero will stop Resolve trying to pass Sapphire images in GPU memory. One of the GPUs should still get used for Metal acceleration of effects.

1 Like

Thanks for your help!

Sadly this does not work. All Sapphire Filter still crash as soon as they get activated.

I believe it has something to do with Metal GPU-Processing:
Using Metal i tried to deactivate the GPUs in Resolve except just one (used the “Standard” Apple Pro VEGA II) and Sapphire still crashed.

When i switched to OpenCL everything works fine (but is slow, compared to Metal processing).

Any ideas what’s going wrong?
THANKS!

Am i the only one with this issue?
I still can’t launch any SAPPHIRE Filter…. :thinking:

This seems happen with Resolve on Mac with multiple gpus on Metal
Some questions:
Are you running free Resolve or Resolve Studio?
Can you try setting use_gpu: no in s_config?
Does Sapphire 2021 still work (just to confirm)?

Hi !
I use DR Studio - not the free version.

Disabling GPU in the config file works.No crashes… but also: no GPU :slight_smile:

I don´t have Sapphire 2021 on my machine. But they worked fine with the same config (same machine, same os, same resolve version).

Thanks AGAIN!!

Thanks for the detailed report. Someone else reported similar circumstances with a Vega Duo. Work to fix crashing Resolve on multiple Metal GPUs is underway for Sapphire 2022’s first maintenance update, which can be expected some time after the Thanksgiving break.

1 Like

thanks and good to know i am not alone with this
and the devs are going to fix it.m :+1:

1 Like

Any news about the fix/update?
Or maybe a “beta” i can test…
THANKS!!

The crashing has been reproduced here in-house. The fix is still being finicky. Thanks for offering to test when ready, since it would be good to confirm function on your fine hw.

Hey

Just so you feel less alone, I want to share that I encountered the same behavior here.

My Machine is a 16-Core 2019 MacPro with 192 GB, RADEON VEGA II PRO DUO. I was on macOS 10.5 but upgraded to 11.6 in hope that will solve the crashes, until I saw this thread, that it.

Resolve 17.3.2.

Setting setting use_gpu to no solved the crashes

Hi, I just got a new MacBook Pro M1 max 64GB, 32 core GPU. My host App is Resolve Studio 17.4.2 running Sapphire v2022.0 version 15.

Sapphire resolve/fusion running under metal gpu isn’t stable for me either, but once I disabled the gpu via config file it seems to be working. looking forward to the fix :slight_smile:

1 Like

Hi guys!
i don’t want to put any pressure in here, but… well…any news about
the bugfix?
thanks !

This fix along with several other stabilizations are in Sapphire v2022.01, which is set to be pushed out imminently.

great to hear and thanks for your (and the teams) hard work and excellent communication here!!!

Thanks, guys !!
Downloaded 2022.01 today and it works fine so far!!
Back in the game now!
Good job!! :+1:

I seem to be having this problem. When I add a Sapphire OFX to a Resolve clip, it causes a hang and I have to force quit Resolve. I have updated both Sapphire and Resolve Studio to the most recent version. I have added the line to the Sapphire settings. Still doesn’t work. I am using a Macbook Pro (intel) with Mac OS 11.4

Any suggestions?

1 Like

Did you update Sapphire to the latest version (2022.01)?
That fixed it for me…

yes, I updated all versions of Sapphire on my system via the Boris Manager.

Not the same issue exactly, but wanted to report I was having a different issue that was resolved by that terminal command dstoops wrote out.
Using Sapphire 2022.02 on Resolve 17.4.4, Sapphire was throwing random frames out on the first frame of an FX instance. For example, I had a clip with a Swish3D transition on the beginning of that clip. When I rendered the timeline, I would see an unrelated frame pop up at the first frame of the transition. I’ve been tearing my hair out all evening trying to figure this out. I tried the terminal command dstoops added and it rendered normally for the first time.

Using a M1 Max Macbook Pro, latest version of Monterey, latest version of Resolve 17, and latest version of Sapphire.