Sapphire NightSky Effect

I tried a small test project using S_NightSky effect.

It uses several expressions for its parameters, and with them I see a strange problems - some of the frames show several stars jumping for one frame and then returning back to their positions in the next frame.
(The number of such frames depends on unknown factors, but I see at least one such frame in the example).

Can someone check the attached project and test whether this situation is reproducible?
Stars-Test.aep (190.5 KB)

Try turning off all the “Twinkle” parameters. That is on by default and turns the brightness of the stars up and down for a realistic “twinkle”, but in your case, it might look odd with the large pan and be causing them to appear to be jumping.

Thanks,
Brian

Here is an examples of the “jump” (slowed down).
Doesn’t look like twinkle at all.

I have uploaded two full exported videos here:

I think you are getting hung up on the flicker parameter as well. I should have clarified, turn down ALL the parameters in the twinkle category, there’s a bunch in there, including flicker (which is different than twinkle). Here’s an example of everything off, which will render out just an “always on” starfield.

This should solve your problem. Also, look at all the parameters in any given Sapphire effect, you can get a ton of different results.

Thanks,
Brian

Brian,
Thank you for your answer!

I turned off all the twinkle and flicker parameters, just to be sure.
Have you tried my project? It has several expressions for other parameters, and starfield in it looks different from your video.

Here is a 2-second part.

Do you see the problem?

I see the problem happening in your project. There’s definitely a “jump” at frame 112. Can you duplicate the problem with straight parameter animation? I’m wondering if it is an issue with the expression, or a couple of things combining to cause it. If you can duplicate it using straight animation (no expressions) that would show if it is a problem with NightSky or perhaps something else.

Alan.

If I remove all the expressions, the problem is not reproducible.
You may see it for yourself if you disable the expressions, there are keyframes with similar (but not exactly the same) animation.
So, there seems to be something with interaction of the plugin with expressions in this case.

The expressions themselves are not higher mathematics. And they don’t contain some kind of unpredictable functions, so I can not understand the reasons of such strange behavior.

Looking through your project, the problem is with your expressions. As a plugin, our params are simply linked to the expression, we couldn’t have a bug there that would cause some sort of unexpected behavior. Now, if you could replicate the behavior with the expression turned off, that would be a problem. But that’s not the case here.

I would say that it’s some interaction of the plugin and expressions.
If you look at the resulting values of expression calculations, there’s nothing there that could lead to such jumps.
But what are the values that the plugin is using? There is no way for me to see, i see only the result - and this result clearly tells me that there is something wrong in the processing of these values.

I’ll direct message you and we can chat about it.

I returned to the problem and tested it again, now turning off all the expressions.
And the problem was still there! I was wrong thinking that it cannot be reproduced without expressions.
So, the conclusion that “the problem is with your expressions” must be wrong. It is still there, just didn’t occur at that particular time.

I just took a look at the original project again, and if you check the “bypass Mocha” parameter (in the “Mocha” section) the jump does not happen. I don’t think your project is actually using Mocha, is it? If not, I wonder what is going on.

Alan, thank you!

I don’t use Mocha in the project, indeed.
I enabled “bypass Mocha” and turned off the expressions - and don’t see any stars jumping.

Not so with expressions enabled, unfortunately. It still has jumps.
This is all rather strange.

Strange – for me all I have to do is check “bypass Mocha” in the S_NightSky effect and the jumping stops. Expressions are still enabled.

Could you please try increasing the output resolution to 4K?
Will it still produce the result without jumps?

I used the project you sent which was already 4k 25 fps. I changed one parameter (checked the “bypass Mocha” parameter.

I’ve attached the modified project here. The current frame is very close to a place where the jump happened, within two or three frames.

Stars-Test Mocha bypassed.aep.zip (17.8 KB)

In the original project the output file settings are reducing the pictures size.
And if I choose to save to another format with the 4K resolution, the probability of “jumps” seems to increase.

I never rendered – I just looked at it in AE. Are you saying that what you see in AE does not match what you see when rendering?

I was rendering because the results were unreliable. The jumps were not always happening at the same frame.
Yes, the problem can be seen in preview, too. It was simply easier for me to check after rendering.

I rendered again from the the test project - and the jump is not there. But in another project simply turning off Mocha didn’t help. I will try to check again and come back with the results.
It looks like some concurrency issue due to the elusive nature of the bug.