Send Read Node to Mocha

HI all!

I’ve set up this Send to Mocha script that can be used to send a Read node to Mocha from within Nuke.
A few things I’ve wondered if it can be fixed?

  • The splash screen gets in the way of the new project dialogue box. I guess Mocha isn’t used to having that box up straight away when you usually start it up. Is there a flag or something to prevent Mocha from displaying the splash screen at all?

  • IF I’ve previously used sent something to Mocha and want to go back to the mocha project, selecting the Read node and pressing ‘Send to Mocha’ will attempt to create a new project. It would be great if it just opened the already existing project. I have worked at a few VFX studios where this is set up…

Currently on MacOS with Mocha Pro 2020.5.

Thanks!
Lee

You can disable the splash screen in Mocha preferences and then restart the host, it should remember that setting. But if you’re using multiple licenses this can prevent the user from realizing they are running in unlicensed mode.

To have it open an exiting project you’re probably going to have to set a variable up for that. Let me see if @martinb has any suggestions.

I imagine you have already read our python guide? https://borisfx.com/support/documentation/mocha/python/

Thanks Mary. I can’t see the option to disable the splash screen - where is it in preferences??

I have not thoroughly looked through the Python guide, but to be honest it’s a little beyond my skills right now. I only just managed to get the offical python script working, ha!

Sorry, I told you the wrong thing. It’s actually on the splash screen, it’s the checkbox labelled “show next time.” Just uncheck that box.

Hey Mary, it’s not there. I’m talking about the app splash screen that appears (and disappears) when you open mocha.

There’s another forum post about this using Mocha from AE, where the splash screen gets in the way of the project setup panel. It’s essentially that issue in Nuke aswell.

I checked to make sure, it is on the splash screen. Highlighted for ease.

Ah, so the splash screen is disabled and it is still doing this?

Sorry I forgot to get back to you sooner.

To me, this is the ‘welcome screen’. This never appears since I unchecked Show Next Time. That’s expected.

I’m referring to a screen similar to that which is the product splash screen that shows up as the program is launching (it appears before the UI L). On my Mac this is staying on until I create a project but gets in the way of doing so. I’d send a screen recording but I don’t have access to that Mac for a while.

I’ve actually since moved to Windows though and this problem doesn’t exist.

But the point about opening a file if it already exists would be a good addition, that behaviour is still the same on both platforms.

1 Like

Hmm, I can check with @martinb and see if there’s anything that we can make a user story about with this, so we can add it to our wish list. Thanks.

Hey lee,

That is odd, the splash screen should only hang around until the GUI is loaded. Perhaps this has something to do with how the process is loaded. I’ll need to check it out.

The Nuke freebie for “send to mocha” is in dire need of an overhaul as I wrote it several years ago. When I get a chance to rewrite it, I can add the functionality to look for the existing projects. :slight_smile:

2 Likes