Setting the adjust track to a shape?

Hi all,
I am trying to figure how to export a shape that I have tracked, and then used adjust track to refine. The shape export doesn’t seem to use the data from the adjusted track. What am I doing wrong?

Thanks in advance!

What Mocha build and Host application are you using? In case AE, do you try to create a Mask via the “Create AE masks” button, or by exporting the Shapes from Mocha interface? I’ve just doublechecked both scenarios, and shape updates accordingly in both cases. There was a bug in older version, where AdjustTrack refinements won’t export to AE correctly, but we fixed that. Can you try updating to the latest Mocha release and see if that helps?

Thanks very much Elizabeth! Unfortunately, I am using Flame as the host app so that procedure won’t work. I have to export the shape data to a gmask tracer. Normally, this works great! Giving me my Bezier splines and tracked axis. However, if I do an adjust track on Mocha to refine my tracking, that newer tracking data does not get saved to the exported shape. Does this make sense?

Hmm, thanks for illuminating this. Need to doublecheck if this expected behavior with @martinb
But just to be clear, you are on the latest Mocha 9.5.5 build, right? This should be displayed under Help/About menu

Actually we are on 9.5.4. I’ll have my engineering team upgrade me to the latest next month when we upgrade our Flames. We have pretty strict security policies at my shop so our Flames aren’t connected to the internet.

I thought there was a button somewhere that tells Mocha to respect the adjusted track when exporting shapes, but I can’t seem to find it.

Is this shape linked to another track or is it the tracked shape itself?

Nope. Keping it simple. Tracking a single shape, using adjust track to fine tune it, then attempting to export the shape using the “Flame Tracer (Shape + Axis)” selection of the track tab. There is no export shape in the adjust track tab.

I thought it is as simple as selecting the “Adjusted” button next to the link to track button, but it doesn’t allow me to check the box.

If the Flame Axis export is not exporting adjust track data, that’s a problem. This may be a defect. I’ll test this and get back to you.

Hmm… the adjusted track export does appear to be working.

Are you using AdjustTrack transform or AdjustTrack Classic in Mocha?

Hey there Martin,
Thanks for looking into this for me! I only use the new Adjust Track tool. I’ve never used the classic version.

1 Like

Good to hear!

Then that should definitely work.

Can you tell me some more details about your project?

  • Footage size
  • Frame rate
  • Flame version

If you do a non-tracer format gmask export do you see the same problem?

I think the problem is that the “use adjusted track” button doesn’t allow me to click it so the adjusted data get loaded into the layer.

My footage has been UHD at 23.98 and my Flame is currently 2023.2.

Honestly, I never use the old gmask these days. I’ll give it a try for you though.

You shouldn’t need to use the “Adjusted Track” checkbox if it’s just one layer. that’s just if you link the adjusted track to another spline.

One thing to check is if you have any kind of frame offset that might be causing a drift.

Thanks for the update Martin! No, I’m not doing anything fancy like that. Just a track, then an adjust track to make it look better.

Hey there Martin,
I think I figured out a work around! Thanks to both your answer above and this week’s Office Hours, I got the idea of getting a good track/adjust track with one layer, not really caring about the actual roto shape. Then using another layer’s shape to roto, then linking to the earlier layer’s good, adjusted track (by clicking that button)! I’m going to give it a try later this week.

Thanks so much for your help on this one!

Let me pop in with just another thing you can try. You can actually avoid any linking.

  • After you have you layer tracked & adjusted (with the “bad” shape) - click on this button.
    This will delete all the shape keyframes, but retain the track data.
  • Now you can make roto more precise. Edit the shape that you have, or, draw a new one on the same layer (!) using “Add X-Spline” tool, then delete the first one.


Interesting. I’ve never noticed that button before Elizabeth! I’ll give it a try, but I fear that I will still have the same problem exporting the shape and adjusted track from the same layer. Using a linked layer allows me to use the “adjusted track”. I’ll give it a shot tomorrow and let you know what happens!

Thanks very much,

You shouldn’t be using that checkbox in case all the work was done on one layer. Shapes respects that automatically by default. Just try and let us know how it goes. If it looks good in Mocha but exports wrong to Flame - then that’s a bug we need to investigate deeper.