Shape data exported to Nuke does not match, help?please

I am not sure the best workflow to make the parameters between Nuke and Mocha Pro match so that exported shape data will paste into place in the rotopaint node in Nuke
Parameters that need to match:
clip length / frame rate / interlaced node / pulldown mode / PAR
I have run tests, but so far, all the shape data comes in to the Left of whereit out to be.
Nuke parameters:*
clip length: 1-812 frames (in & out points @ 60 and 190)
frame rate: 24 fps
interlaced mode: have been choosing upper field/odd (will switch to even)
pulldown mode:* haven’t done anything with this
PAR: HD
Mocha Pro parameters:
clip length: 1-812 (same in & out points)
frame rate: 24 fps
(bit depth is set to 24)
interlaced mode: have chosen odd to match Nuke (will switch to even)
pulldown mode - have not set
PAR: HDV 1.333
(I have also chosen PAR: DVDHD Pro (which as I understand it, is relatively the same as HDV
I have also set up the PAR to HD, but still the same problem)
In Nuke, the original footage is 1440x1080_50i, but it has a Reformat Node applied (1920x1080) and a Field Select
node (even) applied.
In Mocha Pro, same footage imported - 1440x1080_50i HDV, but for the Pixel Aspect Ratio, do I go with HDV 1.333 OR do I make the PAR HD to match the final plate in Nuke?
Any advice or feedback would be greatly appreciated.
Thanks!
Glen

Hi Martin

the frame offset in mocha pro is 1
I am not sure where to set the frame offset in nuke? I have searched, but haven’t figured out yet.
Can you tell me where the frame offset parameter is in nuke?

thanks

I am not sure the best workflow to make the parameters between Nuke and Mocha Pro match so that exported shape data will paste into place in the rotopaint node in Nuke

Parameters that need to match:
clip length / frame rate / interlaced node / pulldown mode / PAR

I have run tests, but so far, all the shape data comes in to the Left of whereit out to be.

Nuke parameters:*
clip length: 1-812 frames (in & out points @ 60 and 190)
frame rate: 24 fps
interlaced mode: have been choosing upper field/odd (will switch to even)
pulldown mode:* haven’t done anything with this
PAR: HD

Mocha Pro parameters:
clip length: 1-812 (same in & out points)
frame rate: 24 fps
(bit depth is set to 24)
interlaced mode: have chosen odd to match Nuke (will switch to even)
pulldown mode - have not set
PAR: HDV 1.333
(I have also chosen PAR: DVDHD Pro (which as I understand it, is relatively the same as HDV
I have also set up the PAR to HD, but still the same problem)

In Nuke, the original footage is 1440x1080_50i, but it has a Reformat Node applied (1920x1080) and a Field Select
node (even) applied.

In Mocha Pro, same footage imported - 1440x1080_50i HDV, but for the Pixel Aspect Ratio, do I go with HDV 1.333 OR do I make the PAR HD to match the final plate in Nuke?

Any advice or feedback would be greatly appreciated.

Thanks!

Glen

Hi Martin
Thanks for the response!
I have tried: export shape data & copy to clipboard into the Rotopaint node.
I am using 3.0.1
When i tried “export tracking data”, i got the “errors occurred during the xport. Some data may be missing or invalid.” Does this error occur when the tracking data is not “good” or off?
Thanks!

Hi Martin

Thanks for the response!

I have tried: export shape data & copy to clipboard into the Rotopaint node.
I am using 3.0.1

When i tried “export tracking data”, i got the “errors occurred during the xport. Some data may be missing or invalid.” Does this error occur when the tracking data is not “good” or off?

Thanks!

Hi Martin,
Thanks. Will do on the upgrade.
I was sticking with the exporting shape date and pasting into a rotospaint node because it wasn’t giving me any errors. I wasn’t getting any error on exporting the shape data and I was checking my tracked data by tuning on the surface and resizing so the gird didn’t go crazy. It seemed like a decent track and the roto linked to it looked decent. My problem is that the shape date pasted into Nuke kept coming in over to the left.
is that definitely a problem of the track being off? Or is it a problem with the paramters not matching between mocha and Nuke?
do the parameters I am using that i listed make sense per Nuke and mocha pro?
I will also go back and recheck the surface and shape.
Thanks!

Hi Martin,

Thanks. Will do on the upgrade.

I was sticking with the exporting shape date and pasting into a rotospaint node because it wasn’t giving me any errors. I wasn’t getting any error on exporting the shape data and I was checking my tracked data by tuning on the surface and resizing so the gird didn’t go crazy. It seemed like a decent track and the roto linked to it looked decent. My problem is that the shape date pasted into Nuke kept coming in over to the left.
is that definitely a problem of the track being off? Or is it a problem with the paramters not matching between mocha and Nuke?

do the parameters I am using that i listed make sense per Nuke and mocha pro?

I will also go back and recheck the surface and shape.

Thanks!

Hi Martin
the frame offset in mocha pro is 1
I am not sure where to set the frame offset in nuke? I have searched, but haven’t figured out yet.
Can you tell me where the frame offset parameter is in nuke?
thanks

Hi glent12,
Are you using the RotoPaint node specifically, or the 6.2 roto export?
Which version of Pro are you using?

Hi glent12,

Are you using the RotoPaint node specifically, or the 6.2 roto export?

Which version of Pro are you using?

First of all, I recommend updating to 3.1.0, as this is a free update and it fixes a few defects.
Secondly, if you are getting an error message on export, your tracking data may be incorrect. turn on the surface to check if it is behaving normally. If the surface disappears or the corners go crazy, you may need to retrack the shape.

First of all, I recommend updating to 3.1.0, as this is a free update and it fixes a few defects.

Secondly, if you are getting an error message on export, your tracking data may be incorrect. turn on the surface to check if it is behaving normally. If the surface disappears or the corners go crazy, you may need to retrack the shape.

Do you have the same frame offset in both apps?

Do you have the same frame offset in both apps?