Shape Export problem

Hello, guys.

How r u doing? i’m stuck. i’m near to get depressed) the thing is i’ve rotoscoped a shot, and i can’t export properly shape to AE. i’ve seen a lot of mocha tutorials and doing in exact same way like in videos. what can be wrong? i’ve restarted mocha, AE and my machine about ten times. it doesn’t work. problem is that imported data in AE looks different than in mocha.
may be problem in pixel aspect ratio? in mocha and in AE they’re a bit (really small) different. in mocha it’s a 1.0, and in AE it’s “Square pixel”. but when i did a snapshot of those, than ratios was slightly missmatched. what can solve this problem as well?
thanks for ur time.

Hi sandalya, have you covered the check points from the FAQ?
http://forum.imagineersystems.com/showthread.php?t=856

  • Check to see if the aspect ratio of your After Effects composition and the mocha project are the same
  • Check to see if the frame rate of your After Effects composition and the mocha project are the same
  • Make sure you are exporting and pasting your data to the right frame in After Effects
  • If you are pasting to a different layer to the footage, is the layer the same size as the footage?
    An AR of 1.0 is the same as Square Pixel. Is the shape starting in the correct place on frame 1?

Hi sandalya, have you covered the check points from the FAQ?

http://forum.imagineersystems.com/showthread.php?t=856

  • Check to see if the aspect ratio of your After Effects composition and the mocha project are the same
  • Check to see if the frame rate of your After Effects composition and the mocha project are the same
  • Make sure you are exporting and pasting your data to the right frame in After Effects
  • If you are pasting to a different layer to the footage, is the layer the same size as the footage?

An AR of 1.0 is the same as Square Pixel. Is the shape starting in the correct place on frame 1?

Hi sandalya,

Is the footage interlaced?

Hi sandalya,
Is the footage interlaced?

Hi sandalya,

Yes. After Effects handles interlaced footage differently. Here are the steps to take as listed from the FAQ I posted under “Mocha Shape for After Effects Problems”:

Q: When using interlaced footage I paste my shape data and the shape is out of sync, even though I have checked all of the Common Problems

This is due to After Effects interpreting interlaced footage on the timeline as full-field, and mocha interpreting in separate fields. Therefore when the shape data is pasted from mocha to After Effects, mocha has twice as much information to put into the timeline.

The recommended work flow for rotoscoping interlaced video footage (without pulldown) in mocha and sending to mocha shape is as follows:

Using 29.97 source footage*

In mocha:

  1. Import footage. Set the frame rate to 59.94 and the project setting to Separate Fields (NTSC*).
  2. Do your track/roto work
  3. Export your shape data

In After Effects:

  1. Interpret AE footage as interlaced, lower field first*
  2. Set up AE comp NTSC, 59.94 fps and drag the clip to comp > this emulates the double length comp we like we do in mocha: every field is now on a progressive frame
  3. Select desired layer and paste mocha shape data
  4. Finish your composite, then drag that comp to a NTSC 29.97 comp to render
  • For PAL use 25i, 50p, and upper field first

Hi sandalya,
Yes. After Effects handles interlaced footage differently. Here are the steps to take as listed from the FAQ I posted under “Mocha Shape for After Effects Problems”:
Q: When using interlaced footage I paste my shape data and the shape is out of sync, even though I have checked all of the Common Problems
This is due to After Effects interpreting interlaced footage on the timeline as full-field, and mocha interpreting in separate fields. Therefore when the shape data is pasted from mocha to After Effects, mocha has twice as much information to put into the timeline.
The recommended work flow for rotoscoping interlaced video footage (without pulldown) in mocha and sending to mocha shape is as follows:
Using 29.97 source footage*
In mocha:

  1. Import footage. Set the frame rate to 59.94 and the project setting to Separate Fields (NTSC*).
  2. Do your track/roto work
  3. Export your shape data
    In After Effects:
  4. Interpret AE footage as interlaced, lower field first*
  5. Set up AE comp NTSC, 59.94 fps and drag the clip to comp > this emulates the double length comp we like we do in mocha: every field is now on a progressive frame
  6. Select desired layer and paste mocha shape data
  7. Finish your composite, then drag that comp to a NTSC 29.97 comp to render
  • For PAL use 25i, 50p, and upper field first

Track individual fields is optional. You only need to set this if there is an obvious difference or vast shift between one field and another on some frames. Most of the time it can be left unchecked.
If you paste the double-frame tracking data into the normal comp, after effects should compress the data to fit the frame rate of the comp you paste it to.

Track individual fields is optional. You only need to set this if there is an obvious difference or vast shift between one field and another on some frames. Most of the time it can be left unchecked.

If you paste the double-frame tracking data into the normal comp, after effects should compress the data to fit the frame rate of the comp you paste it to.

hey, but what about if i would export a footage from AE in JPG sequence for instance before rotoscoping or tacking it in mocha? will it works?

Hello, guys.
How r u doing? i’m stuck. i’m near to get depressed) the thing is i’ve rotoscoped a shot, and i can’t export properly shape to AE. i’ve seen a lot of mocha tutorials and doing in exact same way like in videos. what can be wrong? i’ve restarted mocha, AE and my machine about ten times. it doesn’t work. problem is that imported data in AE looks different than in mocha.
may be problem in pixel aspect ratio? in mocha and in AE they’re a bit (really small) different. in mocha it’s a 1.0, and in AE it’s “Square pixel”. but when i did a snapshot of those, than ratios was slightly missmatched. what can solve this problem as well?
thanks for ur time.

yeap. it can cause a problem?

Hello, martinb.
thanks for ur FAQ. Hope, it will be usefull to me.
Your advices are the basics, that was covers in almost every video tutorial of imageneer systems. yes, footage is DV wide screen, 25 fps set in both appolication, resolutions are match so as pixel aspects. mocha shape imported to a first frame, so it should fits correctly.
here are my settings of both programms. maybe i’ve missed something.

Hello, martinb.

thanks for ur FAQ. Hope, it will be usefull to me.
Your advices are the basics, that was covers in almost every video tutorial of imageneer systems. yes, footage is DV wide screen, 25 fps set in both appolication, resolutions are match so as pixel aspects. mocha shape imported to a first frame, so it should fits correctly.
here are my settings of both programms. maybe i’ve missed something.

hey, but what about if i would export a footage from AE in JPG sequence for instance before rotoscoping or tacking it in mocha? will it works?

yeap. it can cause a problem?

Thanks alot. i’ll try this technique as soon as possible.

Thanks alot. i’ll try this technique as soon as possible.

What still isn’t clear to me is - once you’ve imported at 59.979, and separated fields, there is the check box to “track individual fields” Do you select this or leave it off?
Also, after tracking this project and pasting into a 59.97 comp, the shape works pretty well, but the tracking info (which I also need) pastes at half the length. Thanks!

What still isn’t clear to me is - once you’ve imported at 59.979, and separated fields, there is the check box to “track individual fields” Do you select this or leave it off?

Also, after tracking this project and pasting into a 59.97 comp, the shape works pretty well, but the tracking info (which I also need) pastes at half the length. Thanks!