Spline Changing Shape on Me Mid-Track

I am fairly new to using Mocha AE so it could be user error. I am trying to put together an Iron Man Hud video. The video is only of my face, pretty lit, in front of a black screen. My head does not move much at all.

What I’m trying to do is track my head movements so that the targeting effects and various widgets I add to the composition move along with my head.

My issues are two-fold:

  1. I use the X-spline too and draw a “mask” that covers my eyes, bottom part of my forehead and the bridge of my nose.(I have tried splines that cover my whole face, just my nose, etc) I have tried clicking on all of the track motion options. It follows it great until about 1/3 of the way through. It is still following it correctly but the spline that I drew changes drastically, becoming very shrunk. It stays this shape for the rest of the tracking.

  2. When I save it and return to After Effects I go to add things to the composition such as shapes and widgets. After I hit “Apply Export”, the size of whatever I add is drastically shrunk, sometimes to the point where If I make it larger(or to the original size), it’s very blurry. Which leads me back to problem number 1. The widgets in the comp look great and follow everything great, until it gets to the part in the tracking(again about 1/3 through) where the spline shrinks, then all the widgets follow suit and change in shape and position as well. And if I adjust the shapes/widgets at this point, it affects how they are laid at the beginning of the video.

I use Export Option: “Corner Pin”
Layer Export To: the new layer and select “Source”

What it sounds like is that your track isn’t working properly. Try only tracking your forehead and nose, if you blink, Mocha may be trying to track that motion.

You also must be sure to use the surface tool when you track, that will be what the corner pin will translate to in AE.

And make sure when you are applying your corner pin that you either use a full frame corner pin using align surface, or make sure your insert is the same size as your composition. https://borisfx.com/videos/align-surface-and-mismatched/

Let me know if that helps you.

Cheers,
Mary

Nope none of that helped me.

Not sure why you linked that video as it has options that are no longer available in the current Mocha. Also, I don’t know who’s doing that tutorial but it’s so hard to follow: it’s incredibly fast and does not use terminology either. I hear a lot of “we’re going to move this, in to that, which becomes this”.

What I just tried was separating the 2 minute clip of just my face in to 20 second segments and tracked each one individually. It looked like it worked. My thought was then to place those layers in order so that it makes the 2 minute clip in After Effects then precompose it. Makes sense right? Nope. All of the tracking data went bye bye.

So I then layered each clip in order and brought in the widget that I made and exported it to the first 20 second clip. Works great. I then brought in another copy of the same widget and exported it to the 2nd clip, worked great until 10 second in to it, my widget just disappears completely, reappears and is all stretched out. Then got a warning box saying something about Corner Pin cannot allocate 30000 pixels.

I upped the minimum pixels during each track to 75. I hit the surface button and the align button like you said. All it did was give me brand new problems on a very seemingly buggy and not well put together program.

As I said in my first post I tried masking different parts of my face with the same result. This is getting extremely frustrating as I have a deadline and I have done everything on my end but this software is not doing the very simple task I’m giving it like it’s supposed to. All I want to do is track my face that barely moves and I’ve spent 3 full days on it to no avail.

I thought you’d be able to extrapolate the connection between the surface tool and the corner pin, and the way AE treats corner pins on objects that are not the same size as the comp, even if the exports do not work the same.

That’s actually my tutorial. I regret that you find it unclear.

What it sounds like is that your surface tool is going behind the camera and that the track isn’t locked to the area you are trying to follow, which would further imply a track that isn’t attaching properly. Splitting your face up into twenty second clips won’t matter much, what matters is the track itself and whether or not it is holding onto the area you are trying to track.

When you turn the surface tool on, what do you see?

Have you tried tracking with CPU tracking instead of GPU tracking? It may be that you are getting bad results due to processing on the GPU (if the GPU is unsupported). You can turn GPU tracking off in your Mocha preferences in the GPU tab.

If you like, you can send me your shot and I can take a look at it. Do you by any chance have glass or something transparent over your face that could be causing reflections or shadows mocha is tracking?

Cheers,
Mary

Thanks for the reply. No there is nothing reflective or shadows present.

When I split up the video in to the clips the shape, for the most part, kept its shape instead of going crazy when I tracked the whole video as one.

In the GPU tab I have it reading in yellow font that “GPU processing is not supported. See logfile for details.” The check box is clicked to use GPU processing and I cannot unclick it as it is greyed out. I have the GTX 1070.

After I draw my spline and hit Surface it forms a blue rectangle inside the spline shape.

The blue rectangle, the surface tool, is what your track is doing. The spline means nothing to the track except that the spline is where the track is looking.

If your shapes flipped in on themselves, that tells me the perspective of the track is actually causing a problem, that the surface tool “went behind the camera.” This is when the perspective shift turns hard enough that the surface tool moves beyond the camera plane and mocha can not calculate the track.

To solve this, try using shear/skew instead of perspective on the problem areas of your track. Also, you might need to use adjust track to adjust the surface tool (and the track) over time.

Your corner pin in AE will always be a direct translation of the surface tool. Bad track= bad surface tool= bad corner pin= unhappy compositing camper.

Lastly, track in this area I’ve traced for you for better results. Avoid your eyes. They move too much. You need consistent planar data, that is pixels all moving together in one direction, to get a good track. Turn your surface on the entire time you’re tracking so you can see what your track is doing.

Cheers,
Mary

Thanks. Attempting now. What about the GPU issue I had?

When you say adjust the track are you referring to the blue rectangle or the white dotted one?

Is the blue rectangle not supposed to move at all? I’m getting decent movement from it.

The Blue Surface rectangle keeps vanishing and then reappearing about 2/3 through the track. The spline shape on my forehead has changed. Not shrunk like before but has moved out past even my hair on the left side of my face(so the right side if you’re looking at the pic straight on.) It has stayed like that for a little while now. The nose really hasn’t moved much overall however.

aep%20_%204_25_2019%206_29_23%20PM

Am I being Punkd or something. I mean honestly what is this software? Why can’t your software follow the very little movements of my head? I don’t care about my mouth, eyes, etc. Just want it follow my head. There’s nothing complicated about my shot. Sorry for sounding short, but I have literally spent 3 full days trying to figure this out. Just spent an hour with this track based on your specifications to have it turn out worse than before.

That error is an AE error having to do with the size of your insert. I’m happy to take a look at your shot with you. You can email me at maryp@borisfx.com with the best number to reach you at.

I have not heard from you, so please let me know the best number to reach you at in email so that I can help you before I am gone for the weekend.

Cheers,
Mary