Spline point jump far away for no reason

Having a strange problem. Trying to track a stop sign in 360 VR. It tracks well for a few frames and suddenly one of the spline points jumps a mile away seeming for no reason. There is no keyframe there.

Screen Shot 2020-07-15 at 7.37.11 PM

yesss very frustrating. Now any time I try to track anything I get the weird jumping around of the mask shape. Totally unable to track anything all of a sudden.

Clear cache, disable GPU tracking and restart?

will try that. I notice that all is fine until I try to set a new keyframe. then it goes nuts.

This looks like a perspective distortion issue.

  • How much does the sign move in perspective?
  • What is your surface looking like?
  • What are your tracking parameters set to?
  • What is the Mocha Pro version?

With GPU disabled it’s better but the problem still occurs. Only happens track when I add a keyframe. The next frame after is a wild jump to somewhere else. Sometimes if I go back and tweak the shape at that keyframe it is ok and tracks normally again but most times not. Version is most recent version.

Please see my questions above. I need more details. :slight_smile:

  • How much does the sign move in perspective?
    it rotates about 120 degrees

  • What is your surface looking like?
    very textured. I think you can see it in the screen grab above

  • What are your tracking parameters set to?
    I have tried every combination with exactly the same problem. Translate scale rotation. tried all of them. tried just translation. Min pixels set to 25. Set to 90. Something is very screwed up.

  • What is the Mocha Pro version?
    2020.5 when i check software update it tells me i am at the latest version.

All has been working well until today. Now any time I set a key frame it goes nuts. No keyframe no problem. Have cleared cache. Turned off GPU tracking. Restarted host. Restarted computer. Totally unable to work all of a sudden.

I should add that I have tracked the same shot before with no problems. I need to do it again to alter some elements so I need a new track. Now I can’t track anything in any shot.

Okay , knowing that you could track this before helps.

By surface, I mean your surface tool, the blue rectangle.

Can you send us a sample of the shot to check?

ok. How to send it?

ok here is another thing. If I set a keyframe by adjusting the bounding box, no problem. If I move one of the x-spline nodes… it goes nuts. I’m not making this up.

Ao I was able to do the track and the replace. As long as I don’t touch the splines… just the bounding box. Very weird. If I do touch the spline it goes nuts.

1 Like

Bump. Any suggestions. Reinstall? Turning off GPU rendering does not help. Only slows everything down. I have had this problem before, but very intermittently. A small shift in a node seemed to clear it up. but now it’s happening all over. One new thing: I am getting a message every time I first invoke mocha that says “licensing error”licencing , even though I have until August and it says that.

When you say a shift in a node seemed to clear it up… are you using Fusion or NUKE? Do you have any nodes applied before channeling into Mocha Pro?

Sorry. By node I mean a control point on the spline. I can alter the bounding box but not the individual control point on the spline. I hope that is understandable. My host is after effects. example

I have also been getting some “out of memory” errors lately. that is new. I have 64 GB ram and nothing else running.

I note that as I render out the remove memory use is now upwards of 57 Gb and counting. Does Mocha render to memory or to the drive? Does it try to cache renders on the system drive?

Yes - you can go to File>Clear Cache.

Is there any way to set the cache to an external drive?