Stabilized footage revoked after applying a mask?

I have some footage that is slightly unstable. I have used Mocha AE tracking data to stabilize the footage without any issues, however, once I try to create a mask, either in Mocha AE or After Effects directly, the stabilization disappears. I then tried to pre-composed the stabilized footage / layer and then apply a mask, but still gave me the same result. I’m probably overlooking something super simple. That being said, if someone could point me in the right direction of a tutorial that covers this, or some documentation that covers this, I would greatly appreciate it. Thanks so much!

If I understand your issue, you are applying Mocha AE and using the inverted tracking data to stabilize?

If you want to mask after stabilization, the precomp method should be working. When you precomp the layer, make sure that you use the “move all attributes into new comp” selection. The “leave all” option will retain the Mocha AE plugin on your top layer and the mask would not work with stabilize.

Hope this helps

image

Like a charm sir! Rosss, I very much appreciate you taking the time to explain how to do this. The screenshot also helped immensely. I was almost there, just needed that extra nudge. :+1::+1: Thank you!